Crystal report Dll s in Bin folder RRS feed

All replies

  • User1196771204 posted

    Hi Ajith,

    There are few things you need to check in order to make sure your current shared host/server does support Crystal Report 2008:

    1. You need to make sure the Crystal Report installed on the server matches the crystal report used on your code
    2. You need to use the server crystal report assemblies on your web.config 
    3. You need to make sure your current host support Full Trust
    4. You need to make sure the application pool of your site is set to operate under LOCAL SERVICE.

    If your current host is unable to solve this issue, please consider hosting your Crystal Report site with asphostcentral.com. They have supported Crystal Report 2008 and even the latest Crystal Report 2010 (v13)

    Please mark this response as an "answer" if it helps you. Thanks heaps! 

    Thursday, February 16, 2012 9:33 PM
  • User-37275327 posted

    As far as  i know, you need to run CR runtime on the server. But said it is shared hosting server. You nedd to get a deidcated hosting server.

    Thursday, February 16, 2012 10:46 PM
  • User1196771204 posted

    hi cnranasinghe,

    just for your information, Crystal Report DOES work on a shared server. You do not need to spend hundred of bucks every month just to host your crystal report. Even though it is a shared server, crystal report will work if full trust is enabled.

    hope this helps! :)

    Friday, February 17, 2012 2:24 AM
  • User-37275327 posted


    Thanks a lot for the feedback.  I never host on shared hosting server. Can u please let me know the way how to do that?. Assum application is developed in VS2008. Your response is much appriciated.


    Friday, February 17, 2012 2:53 AM
  • User1692181589 posted


                   I want to include CRRedist2008_x86  in my websetup project. Please Help me .I am trying to achive this form last one week plzzzz


    Thursday, April 12, 2012 10:08 AM
  • User1219651576 posted

    i am also getting error on server... 

    Either the Crystal Reports registry key permissions are insufficient or the Crystal Reports runtime is not installed correctly.

    Crystal report is working fine on local.. i have installed CR 10.5(VS .NET 2008) CRRedist2008_x64.msi (64 bit Intel) but still getting error...

    Monday, April 16, 2012 8:08 AM
  • User470161102 posted

    I have a similar issue. I have hosted our site at www.softsyshosting.com . Our host said that Crystal Report

    10.5.3700.0 runtime is installed and their other customers are using it successfully. 

    Unfortunately, all of my efforts so far have failed:

    My development environment is as follows:

    -Vs 2008

    -Crystal Reports for VS 2008

    -Compiled for x86

    In the begining I referenced the dll's but not included them in BIN folder. Later our Host adviced to put the DLL's in the BIN folder and reference them in your program. I tried this but still no success.

    someone please help to resolve this issue.

    Tuesday, November 20, 2012 3:09 AM
  • User-37275327 posted

    One point, check Sever 32bit or 64bit. This must aling with CR redistributables. Install correct one.

    Tuesday, November 20, 2012 6:30 AM
  • User470161102 posted

    I am sorry I forgot to mention that the Hosting is on Shared Web server. 

    Therefore, I do not have the option of installing/uninstalling.

    The reps informed me that 10.5.3700.0 is already installed on the Server and I have no option but to use this one.

    They have also enabled the 32-bit applications in the IIS.

    I am not sure what version of redistributables was installed x86 or x64? but one thing I am sure is that it is 10.5.3700.0

    I just checked my PC and found that I picked the Dll's from the following location:

    C:\Program Files (x86)\Business Objects\Common\2.8\managed

    I assume that all these files are x86 and the one on Server might be x64. That might be causing this conflict.

    Let me try using the files from x64 redistributables.

    Thursday, November 22, 2012 6:02 AM