locked
Access Denied when trying to activate Office SharePoint Server Publishing feature RRS feed

  • Question

  • Hi,
       I m trying to create Report Center site under Enterprise tab.When i try to create it , i get this message

    "The Office SharePoint Server Publishing Infrastructure feature must be activated at the site collection level before the Publishing feature can be activated."

    Since i as a System acount (Site Owner) of this site collection try to activate thru site collection feature.I get Access Denied message.Where i m going wrong.Please guide me.

    Thanks

    Mehmood
    • Moved by Michael Washam - MSFT Wednesday, August 20, 2008 3:02 PM wrong forum (Moved from SharePoint - Development and Programming to SharePoint - Setup, Upgrade, Administration and Operation)
    Wednesday, August 20, 2008 1:51 PM

Answers

  • A site owner by default has 'Full Control'.  You need to be a Site Collection Administrator. 
    Shannon Bray - MCT, MCPD, MCTS, MCITP
    • Marked as answer by M Hussain Thursday, August 21, 2008 5:19 AM
    Wednesday, August 20, 2008 5:11 PM

All replies

  • Moving to the admin forum
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, August 20, 2008 3:02 PM
  • A site owner by default has 'Full Control'.  You need to be a Site Collection Administrator. 
    Shannon Bray - MCT, MCPD, MCTS, MCITP
    • Marked as answer by M Hussain Thursday, August 21, 2008 5:19 AM
    Wednesday, August 20, 2008 5:11 PM
  • Hi Bray,
                Its working now, Thanks a lot.
    Mehmood
    Thursday, August 21, 2008 5:20 AM
  • Hi Bray,

    I have the same issue.I'm new to sharepoint technologies.I would appreciate you If I get your help.Thanks

    Thursday, March 5, 2009 4:28 AM
  •  

    To solve the ‘Access Denied’ problem you need to elevate the permissions of the AppPool of the web application on which you are trying to activate the Publishing Infrastructure feature.

    One way to achieve this is to temporarily change the AppPool of the web application…

    1. Open IIS Admin.
    2. Location the Web Site for your WSS web application.
    3. Goto to the properties and select the ‘Home Directory’ tab.
    4. Change the AppPool to be the same as Central Administration.
    5. IISRESET
    6. Activate the Publishing Infrastructure feature on your site.
    7. Change to AppPool back to the original.
    8. IISRESET.

    This should allow you to enable the feature and use the publishing features within MOSS.

    This is Working...
    By
    Yaseen

    • Proposed as answer by lasertracs Thursday, March 5, 2009 5:02 AM
    Thursday, March 5, 2009 5:02 AM
  • Thanks Yaseen, this worked for me.
    Tuesday, April 20, 2010 7:26 AM