locked
Error when moved application & database to new servers RRS feed

  • Question

  • Hi,                                                                      

    I have two databases one for storing workflow persistence, error logs etc. and other database for storing business related data. I have WCF and WF service deployed in application server and virtual directory named as ‘TestWCF’ and ‘TestWF’ respectively.

    I’m now moving these databases, WCF and WF services to new servers. In new application server, deployed my application in new virtual directory name ‘ProductionWCF’ and ‘ProductionWF’ & not using the old virtual directory name. When I perform any workflow operation, I’m getting following error.

    The execution of an InstancePersistenceCommand was interrupted because the instance key '19b0a82c-7042-0fdd-adf0-00cbeebb4657' was not associated to an instance. This can occur because the instance or key has been cleaned up, or because the key is invalid. The key may be invalid if the message it was generated from was sent at the wrong time or contained incorrect correlation data.

    I moved workflow persistence database too and it has instance key. I found “RelativeApplicationPath” in [System.Activities.DurableInstancing].[ServiceDeploymentsTable] table still referring to old virtual directory name.

    Please let me know whether changing the virtual directory in new name is cause for this issue and resolution to resolve this issue.

    Thanks,

    Vimal

    Wednesday, August 24, 2011 5:07 PM

Answers

  • Change in SiteName, Virtual Directory or Service Name creates Correlation Issues.

     

    • Proposed as answer by Karthikeyan_1977 Saturday, August 27, 2011 3:33 PM
    • Marked as answer by Andrew_Zhu Thursday, September 1, 2011 1:49 AM
    Saturday, August 27, 2011 3:33 PM

All replies

  • Change in SiteName, Virtual Directory or Service Name creates Correlation Issues.

     

    • Proposed as answer by Karthikeyan_1977 Saturday, August 27, 2011 3:33 PM
    • Marked as answer by Andrew_Zhu Thursday, September 1, 2011 1:49 AM
    Saturday, August 27, 2011 3:33 PM
  • We have the same issue.

    The clients of our web application want to move to a new server and this is very important for us.

    Is it possible to fix it somehow all the same?

    May be WF 4.5 will have some solution?

     

    Thanks in advance.

     

    Friday, September 16, 2011 2:29 PM