none
BTS 2010 EDI Party Setup RRS feed

  • Question

  • I am attemping to set up Trading Partner information for a party in BTS 2010. Everything seems to be okay until I hit the the "OK" button. Specifically I am setting up the protocol information for the Profile of a Party. I used pretty much the default settings.

    I get the following error: "Unable to cast object of type 'Microsoft.BizTalk.Administration.Edi.Ext.ComboItem' to type 'System.String'. (Microsoft.BizTalk.Administration.EdiExt).

    Has anyone encountered this before?

    This seems like a bug to me but am not sure.

    • Moved by Ben Cline1Moderator Saturday, December 11, 2010 11:10 PM Related to EDI (From:BizTalk Server General)
    Friday, December 10, 2010 8:43 PM

Answers

  • Hi,

       This seems a UI Bug. Please file a Service request to your microsoft support.

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    • Marked as answer by bstottt Saturday, December 11, 2010 4:59 PM
    Saturday, December 11, 2010 8:57 AM

All replies

  • Hi,

       This seems a UI Bug. Please file a Service request to your microsoft support.

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    • Marked as answer by bstottt Saturday, December 11, 2010 4:59 PM
    Saturday, December 11, 2010 8:57 AM
  • I was wondering if there was ever any answers on this as I am going through the Tutorials for Biztalk 2010, using the SDK that was downloaded.  I am receiving the same error when trying to save.  

    What I did find by trial and error was the if you go to the Contoso-->Fabrikam tab then to Transaction Set List, if you go ahead and enter soemthing in the ST01 (which I went ahead and put the 850-Purchase Order)   Also clicked on the Radio button to Support Transaction Sets from the List.

    Then in Validation put something in the Transaction Type field (again I selected 850-Purchase) then tried to Apply,  if will save for me.  Otherwise I get the same message that appears above.  

    Once again, not sure if it is a problem with the Biztalk 2010 Tutorials for EDI ( http://msdn.microsoft.com/en-us/biztalk/video/gg153513 ) or as you stated above there is a problem with the UI.   Could not go forward unless this was fixed so this was my workaround.  

    Hope this helps. 

    Thursday, July 14, 2011 7:53 PM
  • I've experienced the same thing and it seems like the problem is caused by clicking on a drop down and never clicking on a selection, even if the 'default' first selection is the correct one. When I discovered this I was selecting a value for GS7, and even though T was the value I was trying to select, I had to specifically click it in the drop down list for it to save.

    However sometimes it still has this problem and you can't do anything about it. In that case, you have to cancel out of the window, and re-open and enter in all the information again, but I recommend hitting apply often so if this happens you don't lose a lot of work.

    Friday, July 15, 2011 7:51 PM
  • I got the same error as following 

    TITLE: BizTalk Server Administration

    ------------------------------

    Unable to cast object of type 'Microsoft.BizTalk.Administration.EdiExt.ComboItem' to type 'System.String'. (Microsoft.BizTalk.Administration.EdiExt)

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Solution:

    Its seems to be a UI issue as per earlier friends said, But  for me its working after close and recreating the aggriment  and i continuosly apply the changes for every single changes on the aggriment.

    Dont get hesitate try again!

    Cheers!!!


    Thanks, Vasantha Prabakaran

    • Proposed as answer by Vasantha Praba Wednesday, August 29, 2012 9:47 AM
    Wednesday, August 29, 2012 9:34 AM
  • This is exactly the problem. Same thing happened to me, but with a different drop down (Target namespace). I just had to re-select the value from the drop down, and it worked. 

    Good catch Steve!

    Monday, August 8, 2016 4:03 PM
  • That is the same issue that I was facing too.

    TITLE: BizTalk Server Administration
    ------------------------------
    Unable to cast object of type 'Microsoft.BizTalk.Administration.EdiExt.ComboItem' to type 'System.String'. (Microsoft.BizTalk.Administration.EdiExt)
    ------------------------------
    BUTTONS:
    OK
    ------------------------------

    So I went ahead and re-selected all the drop downs and made sure that I click on the correct value and get them selected. Not sure exactly which value was causing the issue, but that did solve my issue within a minute without having to do the entire process all over again.


    Monday, August 15, 2016 2:00 PM
  • Hello Gyan,

    Please check cumulative update of BTS 2010.


    Monday, August 15, 2016 2:32 PM
  • Your fix/workaround is here.

    https://integrationadventures.wordpress.com/2014/12/03/is-it-a-bug-in-biztalk-server-2013/

    "keep clicking APPLY button after every field change"

    But I believe that till now Microsoft must have provided a patch.

    Wednesday, August 1, 2018 2:48 AM

  • But I believe that till now Microsoft must have provided a patch.

    From the question/answer about it on Stackoverflow, Microsoft did fix it, but so far only for BizTalk 2016
    Wednesday, August 1, 2018 4:35 AM