none
HY024 ERROR [HY024][MICROSOFT][ODBC MICROSOFT ACCESS DRIVER]'(unknown)' is not a valid path RRS feed

  • Question


  • While connecting to Network Access Database (through DSN) following error is coming.OS is Vista.

    ERROR [HY024][MICROSOFT][ODBC MICROSOFT ACCESS DRIVER]'(unknown)' is not a valid path.Make sure that
    the path name is spelled correctly and that you are connected to the server on which the file resides
    Error [IM006][MICROSOFT][ODBC DRIVER MANAGER]DRIVER'S SQLSETCONNECTATTR FAILED

    The application runs properly on Local Machin(where Database is resides).

    If anybody know pls reply.


    Thanks & Regards



    Thursday, January 17, 2008 9:08 AM

Answers

  • Since you're using impersonation and integrated Windows authentication I would suspect that you're being denied on the hop to the remote server, where the database is located. Basic authentication would probably work but with integrated Windows authentication credentials cannot be forwarded to the remote machine unless Kerberos is enabled to provide the authentication from the web server to the remote server.

    Essentially it's not an issue with your code but with the security configuration of your network.
    Paul ~~~~ Microsoft MVP (Visual Basic)
    Tuesday, December 23, 2008 1:05 PM

All replies

  • Hi, I am having the same issue but with a dbase file on a remote machine. (The .DBF file is not on the IIS server)

    When accessing webpage from the local IIS machine it works fine but when I access the webpage from another machine I get this error:

    ERROR [HY024] [Microsoft][ODBC dBASE Driver] '(unknown)' is not a valid path.  Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.
    ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed
    ERROR [HY024] [Microsoft][ODBC dBASE Driver] '(unknown)' is not a valid path.  Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.


    Any help would be greatly apreciated

    This is my web.config settings:

    <connectionStrings>
    <
    add name="ConnectionStringPromoDBase" connectionString="DSN=PROMOS2.DBF
    "
    providerName="System.Data.Odbc"
    />
    </
    connectionStrings>

    <authentication mode="Windows"/>
    <
    identity impersonate="true" />

    Any help would be greatly appreciated

     

    Regards,

    Chris


     


    Chris
    Tuesday, December 23, 2008 5:24 AM
  • Quite possible there is security restriction to access remote folder. Try to see if IIS allows to access that folder. When you create DSN, does it see database?
    Val Mazur (MVP) http://www.xporttools.net
    Tuesday, December 23, 2008 10:39 AM
    Moderator
  • Since you're using impersonation and integrated Windows authentication I would suspect that you're being denied on the hop to the remote server, where the database is located. Basic authentication would probably work but with integrated Windows authentication credentials cannot be forwarded to the remote machine unless Kerberos is enabled to provide the authentication from the web server to the remote server.

    Essentially it's not an issue with your code but with the security configuration of your network.
    Paul ~~~~ Microsoft MVP (Visual Basic)
    Tuesday, December 23, 2008 1:05 PM
  • Hi Val,
    I have changed the security on that folder to everything possible.
    It has no issue at all when I access the page from the actual IIS server but when I access the page from another PC thats when is errors.

    Cheers,
    Chris
    Chris
    Monday, December 29, 2008 10:53 PM
  • Hi Paul,

    I think you are on to something there, but is sill does not work.
     
    On the IIS server I have turned on:
    "Trust this computer for delegation to any service (kerberos only)"

    Do I need to turn it on on the server that has the .DBF file?

    Cheers,
    Chris.


    Chris
    Monday, December 29, 2008 11:06 PM
  • Hi Paul,

    I have got it to work now, you were spot on with:

    "integrated Windows authentication credentials cannot be forwarded to the remote machine unless Kerberos is enabled to provide the authentication from the web server to the remote server"

    It just took a bit of time for this to be applied across the network.

    Thank you very much,

    Chris.
    Chris
    Tuesday, December 30, 2008 12:11 AM
  • Glad you worked it out. The double hop scenario is always a bit tricky since there are a number of factors involved.
    Paul ~~~~ Microsoft MVP (Visual Basic)
    Tuesday, December 30, 2008 2:27 AM
  • I try to connect ODBC with Access Database (through DSN), the following error is coming. OS is Windows 7.

    --------------------------------------------------------------------------

    [Microsoft][ODBC Microsoft Access Driver] '(unknown)' is not a valid path.  Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

    -------------------------------------------------------------------------

    Do you why this happens?

    Thank you.

    Thursday, December 30, 2010 7:07 AM
  • Please post a new question and indicate what your connection string looks like and which version of Windows you are using.
    Paul ~~~~ Microsoft MVP (Visual Basic)
    Thursday, December 30, 2010 12:51 PM
  • Hi I'm having this error

    ERROR [HY024] [Microsoft][ODBC Microsoft Access Driver] '(unknown)' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

    I'm trying to connect to export data to an Access Database which DSN points to a remote server. 

    My application is on Windows Server 2008 64 bits.

    Could you please help?

    Thursday, September 20, 2012 3:34 PM