locked
X2go client for remote desktop connection between linux local machine and windows virtual machine RRS feed

  • Question

  • Hello!

    I am struggling to establish a remote desktop connection from my Ubuntu laptop to a Windows virtual machine (specifically the GeoAI Data Science Virtual Machine: https://docs.microsoft.com/en-us/azure/machine-learning/data-science-virtual-machine/geo-ai-dsvm-overview). I am attempting to do this using X2go client because this works excellently for connecting to my linux DSVM.

    The connection simply times out, returning the error report: "TIMEOUT connecting to IP xxxxxx".

    This is common to all the connection types (LXDE, XFCE etc) and trying both ssh and RDP access.

    The connection DOES work when I connect with the same credentials to the virtual machine from a local machine running windows, but it is obviously not convenient to have to boot into windows each time I need to access my GeoAI DSVM.

    Does anyone have any solutions?

    Thank you very much!

    Friday, May 17, 2019 1:04 AM

All replies

  • Do you have this error with other Windows virtual machines or just the data science one? 
    Monday, May 20, 2019 4:54 PM
  • Thanks for your reply!

    Yes, I've just provisioned another Windows VM and tried to connect from Ubuntu with X2Go and still have the same issues.

    Tuesday, May 21, 2019 7:47 AM
  • Thanks for giving that a go. On the plus side, this does mean it's not a VM issue per say but rather something with X2Go connecting to any Windows VM. 

    We do have a doc on connecting using X2Go which I am sure you saw as it's part of the data science doc 

    https://docs.microsoft.com/en-us/azure/machine-learning/data-science-virtual-machine/linux-dsvm-intro#installing-and-configuring-x2go-client

    Is the Ubuntu VM you are using to connect connected to a corpnet? Could there maybe be firewall issues or networking policies blocking this app from working correctly?

    Tuesday, May 21, 2019 5:53 PM
  • Hi,

    thanks for your reply. I am trying to connect via on my home internet and I do not have any firewall or corpnet restricting this - I also failed to make an RDP connection to this VM on the microsoft campus in Redmond last week.

    I have also tried downloading an alternative RDP client (Remmina) but the issue persists. If needs be I will boot into Windows when I need to use the GeoAI DSVM but it is not very convenient to have to switch OS to access the VM.

    Thursday, May 23, 2019 9:11 AM
  • Interesting. We would probably have better luck with getting you in touch with a Support engineer to jump on a call with you and get it sorted out. 

    Do you have the ability to open a technical support ticket? If not, you can email me at AzCommunity@microsoft.com and provide me with your subscriptionID and link to this thread. I can then enable you for a free support request. 

    Thursday, May 23, 2019 5:55 PM
  • Any update on this thread? 
    Friday, May 31, 2019 7:18 PM
  • Hello,

    please accept my apologies for the slow reply - I was out of the country last week. Is there still an opportunity to speak to a support engineer this week? I have not resolved this problem yet.

    Many thanks again

    Joe

    Monday, June 3, 2019 10:39 AM
  • Hi Joe. Yes of course. I can get you in touch with Support. Please see my above comment and send me an email whenever :)
    Monday, June 3, 2019 3:56 PM