locked
Reporting Services stopped working after account password change . RRS feed

  • Question

  • Hi All,

    Reporting Services stopped working after account password change ...which is used by SSRS Configuration manager.

     I have reset password  in windows service for SSRS logon account then restarted service .

    When I am trying to access ssrs web service url then it thowring below error.

    The report server cannot open a connection to the report server database. The log on failed. (rsInternalError) Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E) .

    Where I have update new password for ssrs config account.
    Please suggest. 

    Tuesday, September 29, 2015 7:26 AM

Answers

  • Hi Mukesh,

    Please refer to the following steps to fix the issue:

    1. Goto Reporting Services Configuration (in Start Menu->Programs->Sql Server->Config Tools.
    2. Click on Execution Account
    3. Uncheck "Specify an execution account". Or change the services account.

    Regards,
    Shrek Li

    • Proposed as answer by 王者荣耀 Thursday, October 8, 2015 1:26 AM
    • Marked as answer by 王者荣耀 Thursday, October 8, 2015 9:23 AM
    Wednesday, October 7, 2015 9:41 AM

All replies

  • Hi Mukesh, 

    According to your description, Reporting Services stopped working after changing the account password in Reporting Services Configuration Manager, right? 

    In your scenario, since you changed the account password, and then access to the Reporting Services web service URL, you get an error. For you issue, you can go to C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\LogFiles this folder to check the log file, please share the error message for us analyzing. 

    Based on the error, we find a thread which has the same error to your scenario. Please refer to this thread: Password change problem - SSRS Account

    If you have any other question, please feel free to ask. 

    Regards, 
    Shrek Li

    Tuesday, September 29, 2015 8:06 AM
  • Hi Mukesh,

    According to your description, you encountered logon failed after you changing the password for the service account. Right?

    Initially you can't open the Report Manager, because when you change services account, you may not reconfigure the SSL in web services.

    Then you can't open Reporting Services Configure Manager, because when you change the password of service account, you also need to update the credential in Services. Otherwise the Reporting Services will stop so that you can't open Reporting Services Configure Manager. It's same thing when starting SQL Server in Services.

    Now you can't open connection to report server database. Firstly, you should check if the service account has permission to access report server database. This issue can occur because the Database Engine instance that hosts the report server database is not configured for remote connections. Please follow the steps below:

    1. Open the SQL Server Configuration Management tool.
    2. Click the triangle in front of “SQL Server Network Configuration”, and click the “Protocols for MSSQLSERVER”. (If you are using a named SQL Server instance, please select the named instance instead.)
    3. Please make sure both the “TCP/IP” and “Named Pipes” protocols are enabled. To enable a protocol, please right-click on the protocol and click “Enable”.

    Reference:
    the report server cannot open a connection: Need help to go right direction                                 

    If you have any question, please feel free to ask.


    Please Dont forget to mark as answer and Helpful Post. It helps others to find relevant posts to the same question. Milan Das

    Tuesday, September 29, 2015 8:26 AM
  • Hi Shrek Li/Milan,


    Yes I encountered logon failed after changing the password for the service account.

    I already updated change password in SSRS services account. When I login from same service account in SSMS then I am able to login and query on dbo of report server database.

    When I try to open "SQL Server Network Configuration" window then It is showing "there is no item message in window" and TCP/IP” and “Named Pipes” protocols are  already enabled.

    When try to access SSRS web service url then it giving error like -

    The report server cannot open a connection to the report server database. The log on failed. (rsInternalError) Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E) .


    Here is error log from log file :-


    library!DefaultDomain 09/29/2015-01:44:26:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: , Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> System.Runtime.InteropServices.COMException: Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E)
       --- End of inner exception stack trace ---;


    Tuesday, September 29, 2015 10:20 AM
  • Hi Mukesh,

    Please refer to the following steps to fix the issue:

    1. Goto Reporting Services Configuration (in Start Menu->Programs->Sql Server->Config Tools.
    2. Click on Execution Account
    3. Uncheck "Specify an execution account". Or change the services account.

    Regards,
    Shrek Li

    • Proposed as answer by 王者荣耀 Thursday, October 8, 2015 1:26 AM
    • Marked as answer by 王者荣耀 Thursday, October 8, 2015 9:23 AM
    Wednesday, October 7, 2015 9:41 AM
  • Hi Shrek Li-

    Thanks for you for your valuable suggestion.

    After long day I am again trying to solve this problem. I did these above changes to reporting server services or manager but did not solve my problem.

    Below is log details-

    library!ReportServer_0-2!15dc!03/31/2016-06:50:39:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: , Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDatabaseLogonFailedException: The report server cannot open a connection to the report server database. The log on failed. ---> System.Runtime.InteropServices.COMException (0x8007052E): Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E)
       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at RSRemoteRpcClient.RemoteLogon.GetRemoteImpToken(String pRPCEndpointName, Int32 type, Guid dataSourceId, String pUserName, String pDomain, String pPassword)
       at Microsoft.ReportingServices.Library.ConnectionConfig.GetImpersonationUser(String userName, String domain, String userPwd)

    Can you please help me out on this issue.

    Thank you.

    Thursday, March 31, 2016 11:53 AM
  • I had this same issue, and the fix was to go to the data sources and edit the credentials used in those data sources. I hope this helps someone else.


    Steve J.

    • Proposed as answer by ShadowInc Monday, August 19, 2019 3:02 PM
    Thursday, February 22, 2018 9:39 PM