locked
Does ODP.NET for .NET Framework 2.0 support ADO.NET Entity Framework? RRS feed

  • Question

  • User2057255475 posted

    I have started working on ADO.Entity Framwork recently. I have installed VS2008 SP1 in my machine and Oracle "ODTwithODAC112030" in the machine. I can able to connect to oracle database uisng the ODP.net provider from server explorer in Visual Studio 2008. But when i try to generate ADO.Net Entity Data Model, i cannot see the ODP.net provider in the list of data provider?  Can any had similar kind of issues? Does ODP.Net work with VS 2008 and ADO.Net Entity Data Model?

    Thanks,

    Praveen.

    Tuesday, September 17, 2013 2:36 AM

Answers

  • User2057255475 posted

    The above mentioned provider will work with VS2010 that is .net framework 4.0 only. It wont support .net framework 3.5 or below

    Thanks,

    Praveen.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, November 13, 2013 7:47 AM

All replies

  • User2056829991 posted

    Yes. For a step by step tutorial of Entity Framework, LINQ, and Model-First for the Oracle database (11G), and using Visual Studio 2010 with .NET 4 see the following Url.

    http://www.oracle.com/webfolder/technetwork/tutorials/obe/db/dotnet/EntityFrameworkOBE/EntityFrameworkOBE.htm

    Hope this helps.

    Tuesday, September 17, 2013 11:10 PM
  • User2057255475 posted

    The above link is for .net framework 4.0.

    As i mentioned in my question i am working with VS2008 SP1. Do you know how we can do the same with VS2008 SP1 edition?

    Thanks,

    Praveen.

    Wednesday, September 18, 2013 1:52 AM
  • User2057255475 posted

    The above mentioned provider will work with VS2010 that is .net framework 4.0 only. It wont support .net framework 3.5 or below

    Thanks,

    Praveen.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, November 13, 2013 7:47 AM