locked
IIS 7 VISTA OS Database Insert/ Update/ Delete Fails RRS feed

  • Question

  • User243579274 posted
    I have a classic ASP application recently moved our development environment from XP to Vista Business.

    The application uses ActiveX DLL's to access data from a SQL 2000 box.

    This application is currently running on IIS 7 from a vista business copy.

    When I try to access the website from a Vista Machine, it reads the data from the database but when it tries to insert or update the records on the database it fails and gives me the following error:

    "3421 Application uses a value of the wrong type for the current operation"

    It is happening with all the functions and sub procedures.

    But the weird thing is when I access the same website from an XP/2000/2003 machines it just works fine.

    If we deploy the application on IIS 6.0 and access it from Vista the database operations works fine.

    I am really stumped on this one.

    I appreciate if someone can help me.

    Thank you
    Friday, April 25, 2008 1:16 PM

All replies

  • User-1853252149 posted

    A 3421 ADO error means you're trying to pass information in the wrong data type, as in trying insert characters in an integer field.

    Jeff

    Friday, April 25, 2008 2:02 PM
  • User243579274 posted
    I know. But the same code base works on IIS 7 when we access from XP/2000/2003 servers. But fails when it is accessed from VISTA OS. All our functions which do Insert / Updates having the same issue. Thank you,
    Friday, April 25, 2008 2:12 PM