none
When i boot with WinCE 7 the Screen is black RRS feed

  • Question

  • i build an system foe WinCE7 with Bay-trail(J1900)

    but when i boot this NK.bin 

    my monitor is black   or this  ---->screenshot URL:http://1drv.ms/1Gm3vbX

    can anyone help me? 

    thank you

    Friday, June 5, 2015 3:44 AM

All replies

  • Hi,

    yeah, your monitor is black, but the screen is a rainbow ;)

    Which graphics driver are you using? - VGAFlat or EMGD

    Did you add "standard shell" component to your project?

    Good luck!

    Friday, June 5, 2015 9:34 AM
  • Hi , thank you for your reply 

    i use the EMGD driver from intel  , but it doesn't work 

    i will check "standard shell" 

    thank you so much

    Monday, June 8, 2015 3:50 AM
  • Hello,

    I have the same problem on two totally different J1900 platforms, for vendor, BIOS and VBIOS.

    The monitor detects a video input at its nominal resolution and 60 Hz, so the monitor EDID has been correctly read. The problem is that the image is totally black.

    I'm using the latest BSP ver. MR5. I have to say that I had similar problems on both platforms, even before trying to load the EMGD driver.

    The strange thing is that I'm used to put WEC7 on ARM and X86 platforms, so there is some "undocumented feature" around :-)

    Friday, March 3, 2017 7:23 AM
  • I don't understand at all what you say is the "strange thing".

    What I do know is that for something to be displayed, software must draw something in the display buffer and a display driver must be running.

    So:

    1. Do you have, and have you verified, a display driver?
    2. Is the display driver outputting to your display?  (not to some other output device)
    3. What is drawing to the display buffer? Earlier in this discussion, there was mention of making sure that the Explorer Shell, or standard shell, is included in the OS.



    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman
    I work for Eurotech

    Monday, March 6, 2017 2:30 PM
    Moderator
  • Hi Folks,

    As indicated by Bruce, can you also try a build with VGA Flat rather than the intel driver and see if that makes a difference? 

    Sincerely,

    IoTGirl

    Monday, March 6, 2017 7:41 PM
    Moderator
  • Hi all,

    No, there is no missing component, nor wrong output device.

    I'm blaming the default definitions of the areas for the memory and the devices in the Intel MR5 BSP I'm using.

    The last image I've built, for example, has the EMGD driver and is causing a "black image" only (perfect H/V sync signals, analog RGB=000) or sometimes with a live cursor on it, on two J1900 boardsof three I have in my lab (I mean different vendors and models). Windows and Linux are running super-stable on all of them.

    I've seen a similar situation with the Flat VGA driver, just after adding or removing optional components. VGA and USB (XHCI/EHCI) seem to be involved in the problem.

    I'll replace the naive search for ACPI memory area to set the top of memory with a E820 call. For now, I've tried to lower the top by an offset, without success.

    Stefano

    Monday, March 6, 2017 8:42 PM
  • Hi Stefano,

    Have you reached out to Intel on this? Or is it a third party BSP?

    Sincerely,

    IoTGirl

    Monday, March 6, 2017 10:08 PM
    Moderator
  • This BSP is a sort of no one's son. :-)

    When you get it, you see Intel logos on every PDF page. When you ask for support, Intel people say you have to ask to third parties to have it, naming two companies.

    One of them never answered to my requests via web forms and e-mails. After repeatly trying to contact them I had only one e-mail saying "someone will contact you in a short time". It was in january.

    The other company took 15 days only to have information about the existance of a the MR5 version of the BSP, released in september 2016.

    So, with these premises, what I need now is first-hand information about this BSP, before reinventing the wheel.

    Stefano

    Tuesday, March 7, 2017 7:27 AM
  • Hi Stefano,

    Can you please provide links? I can't research ownership on your behalf unless I know more specifics.  Did you ask the question on an Intel forum? Can you provide that link?

    Sincerely,

    IoTGirl

    Tuesday, March 7, 2017 6:11 PM
    Moderator
  • Hi IoTGirl,

    Here you can find the link to download the release notes of the BSP in version MR5:

    http://www.intel.com/content/dam/www/public/us/en/documents/release-notes/bsp-for-wec7-and-2013-for-atom-e3800-release-notes.pdf

    The entire BSP should be downloadable from the Adeneo or the BSquare sites. At the time of my research, they were distributing MR4. I have to say that MR5 differs only in a few fixes regarding USB.

    No, I haven't tried to ask on an Intel forum. I've just seen a problem close to mine on this thread and, compulsively, I replied to it.  :-)

    Thank you again

    Stefano

    Tuesday, March 7, 2017 9:04 PM