none
Why word vsto application takes winword's config other than application config RRS feed

  • Question

  • i got a strange issue. In my wordaddin vsto application i created a app.config file. when i run the application it is taking "C:\Program FIles\...\Office15\word.exe.config" as application config.

    why this is happening?really strange... it should choose my app.config as config file.

    my machine is windows 7 and Office 2013 + 32 bit machine.


    Monday, June 17, 2013 3:50 PM

All replies

  • Hi Rosh,

    Thank you for posting in the MSDN Forum.

    I'm trying to involve some senior engineers into this issue and it will take some time. Your patience will be greatly appreciated.

    Sorry for any inconvenience and have a nice day!

    Best regards,


    Quist Zhang [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, June 20, 2013 5:06 AM
    Moderator
  • what vsto runtime? 2010? with sp1 or without?
    Thursday, June 20, 2013 11:21 AM
  • vsto 2007.

    this is a crazy issue. everything is working in Office 2007. when i installed Office 2013 over previous version, it behaving like this.


    • Edited by Rosh Mohan Tuesday, June 25, 2013 3:34 PM dssf
    Monday, June 24, 2013 7:46 AM
  • Wednesday, June 26, 2013 10:15 PM
  • No luck Ajay. Issue is still there, i am not able to figure out where the actual problem begins. i checked both VSTO and manifest, in my manifest file, config file is specified correctly.

    Thursday, June 27, 2013 1:15 PM
  • Is this issue happening on a single machine or multiple machines? If the issue can be reproduced on multiple machines, can you share a scale down version of your vsto application?

    Also, please share more information about your application and the vsto runtime it uses and the exact error/exception message you are getting.

    -Ajay

    Thursday, June 27, 2013 1:57 PM
  • this is happening only in 32 bit windows 7 + Office 2013, for other machine it is running good.

    i have created my addin in visual studio 2008.

    on debug i checked from where my addin reading config file (AppDomain.CurrentDomain.SetupInformation.ConfigurationFile) and i found it is not reading from my app config but reading from "C:\progra..\Office15\word.exe.config"

    when i saw this, i checked my app folder to make sure that my app config is not missed. i can say my vsto application and config are exists in same folder.

    • Edited by Rosh Mohan Thursday, July 4, 2013 6:23 AM more clarification
    Thursday, July 4, 2013 6:21 AM
  • Please share the scaledown version of your application with us so that we can troubleshoot the issue.

    -Ajay

    Friday, July 5, 2013 5:28 PM