locked
Unable to start SQL Server Analysis Services RRS feed

  • Question

  • Hi all,

    As per issue title, suddenly I'm unable to start SQL Server Analysis Services. This isn't the case when I was able to do so earlier this year. I tried to get help via Microsoft Virtual Agent but there were no real solutions. The error messages below as your reference. Appreciate anyone's assistance to take a look into this issue.

    Message-handling subsystem: The message manager for the default locale cannot be found. The locale will be changed to US English. Message-handling subsystem: The message manager for the default locale cannot be found. The locale will be changed to US English. 

    The system specs below as your reference.

    Windows Edition: Windows Server 2012 R2 Standard
    System Type: x64
    SQL Server Edition: MS SQL Server 2012

    Best regards,
    Yea Han
    Tuesday, December 17, 2019 3:15 AM

Answers

  • Is it possible to identify the default locale when SQL Server Analysis Services was installed?

    The issue with the locale is more of a warning. As it says in the message, it will default to using US English. You should check the msmdsrv.log file in the log folder as that should have information about why the service could not start.

    I don't want to use it if possible because SQL Server is located in a production server. If I continue to use it, then I'm unsure about the impact on the entire production server especially the data.

    I'm assuming by the above that you are running both the relational engine and the SSAS engine on the same server. These are two separate services with separate data folders. If you rename the data folder which would be under C:\Program Files\Microsoft SQL Server\MSAS10.MSSQLSERVER\OLAP for a default SSAS 2012 instance it will have zero impact on the relational engine or data (which typically has a folders under C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER


    http://darren.gosbell.com - please mark correct answers

    Wednesday, December 18, 2019 5:40 AM

All replies

  • Hi Yea Han,

    Thanks for your question.

    Do you have that scenario similar to the description of following thread?

    SSAS Sudden startup problem

    Best Regards,

    Will


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 17, 2019 7:52 AM
  • Hi Will,

    Thank you for your response. Yes. I'm facing the issue similar to the thread in the attached link. I read the solution for the issue already and I don't want to use it if possible because SQL Server is located in a production server. If I continue to use it, then I'm unsure about the impact on the entire production server especially the data. Is it possible to identify the default locale when SQL Server Analysis Services was installed?

    Best regards,

    Yea Han

    Wednesday, December 18, 2019 2:34 AM
  • Is it possible to identify the default locale when SQL Server Analysis Services was installed?

    The issue with the locale is more of a warning. As it says in the message, it will default to using US English. You should check the msmdsrv.log file in the log folder as that should have information about why the service could not start.

    I don't want to use it if possible because SQL Server is located in a production server. If I continue to use it, then I'm unsure about the impact on the entire production server especially the data.

    I'm assuming by the above that you are running both the relational engine and the SSAS engine on the same server. These are two separate services with separate data folders. If you rename the data folder which would be under C:\Program Files\Microsoft SQL Server\MSAS10.MSSQLSERVER\OLAP for a default SSAS 2012 instance it will have zero impact on the relational engine or data (which typically has a folders under C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER


    http://darren.gosbell.com - please mark correct answers

    Wednesday, December 18, 2019 5:40 AM
  • Hi Darren,

    Thank you for your response too. I checked the log file already but I believe it can't really tell me why the service can't start at all. But I will take a look at it once again. Anyway, would you recommend me to uninstall and reinstall SQL Server Analysis Services or rename the default SSAS folder is good enough?

    Best regards,

    Yea Han

    Friday, December 20, 2019 2:50 PM
  •  Anyway, would you recommend me to uninstall and reinstall SQL Server Analysis Services or rename the default SSAS folder is good enough?

    I would try renaming the data folder first. Unless you had errors during the install of a service pack or cumulative update which would suggest that your program files might be corrupt in someway the most likely explanation is some issue with one of the core data files.


    http://darren.gosbell.com - please mark correct answers

    Friday, December 20, 2019 8:34 PM
  • Hi Darren,

    Sorry for the late reply. Thank you so much for your assistance. The solutions that you suggested did work after all. I deleted all the files and folders in C:\Program Files\Microsoft SQL Server\MSAS10.MSSQLSERVER\OLAP\Data and started the SQL Server Analysis Services once again. Bingo! The service immediately started running. The issue was caused by the command tool CHKDSK that's similar to the thread in the attached link.

    Best regards,

    Yea Han

    Monday, December 30, 2019 10:35 AM
  • The issue was caused by the command tool CHKDSK that's similar to the thread in the attached link.

    So CHKDSK does not typically cause issues (unless you run it with the option to fix issues allowing data loss), it is used to find faults in disks. This could mean that your disk is failing so I'd suggest keeping a close eye on that disk.


    http://darren.gosbell.com - please mark correct answers

    Tuesday, December 31, 2019 2:17 AM