Access O365 Version 2009 Warning RRS feed

  • General discussion

  • I had just done a minor update on an Access app for a client. When I deployed to the client neither the accde or accdb would open. Message was 'The database you are trying to open requires a newer version of Microsoft Access.'

    I had just deployed an update 2 days ago without any problem.
    In checking, I found that my O365 had been updated to Version 2009 (Build 13231.20262).

    Client's installations are all frozen at Version 2003, due to a performance issue that Microsoft won't fix.
    For the last deployment, my version was 2008.

    Today's change was simply adding a couple of new fields to a simple datasheet form.

    I had to rollback my O365, then revert to the prior version of the app and re-do my changes. Fortunately, saveastext/loadfromtext worked.

    All installations are 32 bit.

    So, this is just a heads up to anyone else with a similar situation.
    • Edited by Alphonse G Monday, October 5, 2020 1:18 AM add info
    Monday, October 5, 2020 12:43 AM

All replies

  • Hi,

    We aren't sure what version that is running. 32bit or 64bit?

    Which is common message when running 64bit Access on a developed 32bit version.

    I still feel 64bit Office365 is buggy. 32bit Office365 much lesser.

    Well...let's see what other MVPs suggest. 

    Monday, October 5, 2020 1:15 AM
  • I edited my post to include 32 bit, however bitness could not have been the problem as I stated that I had just done an update a couple of days ago.
    Monday, October 5, 2020 1:20 AM
  • Hi Alphonse,


    More than a month back as I recalled from another office location, O365 32bit had many problems running from a 2013 version. Where codes worked on 2013 but not in O365. It was just too many errors, had to go back to 2013 runtime install as the default application.

    I don't have O365 on my side, so have stick to 2000 or 2013. Took a long time to clear errors from 2000 to 2013. Just re-edit the codes without changes to clear weird errors. Late bindings and references might be the problem but it never have been a problem from 2007 to 2010.

    Monday, October 5, 2020 3:32 AM
  • Thanks, but this is O365 versions. I've gone through just about every Access version update since 1.0. O365 is not like the old versions style. I've searched and can't find any documentation from Microsoft stating that an Access app compiled in O365 v2009 can't be opened in an earlier O365 version. Something like this should not happen without extensive warnings.
    Monday, October 5, 2020 10:31 AM
  • Hi Alphonse,

    My point is that the VBA codes works differently from older version to newer version.

    For example.

        'xl.Application.Save     'only works with older references Excel 11.0 object library(2000/2003). And 2007.

        xl.Application.ActiveWorkbook.Save  'only working in 2013

    Multiple errors and no errors messages in O365. Can't afford to trace each lines of the codes. No time for that.

    The old save method has no errors in the past and it been working now as well. It's just simply doesn't work with Win 10 and Access 2013.

    I am not going to fix it for O365.

    Tuesday, October 6, 2020 6:15 AM
  • Thanks for your input.
    Tuesday, October 6, 2020 12:44 PM
  • Please see this very similar thread at another forum: 


    The issue may be related to the soon to be released date/time extended datatype (already included but not active) if you are using the decimal datatype. The quote below is by the Access development team leader Ebo Quanseh:

    Very soon, we will ship a new data type, known as Date & Time Extended, which enhances syntax compatibility with SQL while increasing accuracy & level of detail in date & time records.
    While the feature is not yet enabled in Current Channel builds, most of the code for the feature is in the product in an inactive state. Nonetheless, we are aware of a problem that currently exists with this new code. As of today, if you are on version 2005, build 12827.20010 or greater, and you manipulate Decimal fields (Access DataType=Number/FieldSize=Decimal, or SQL DataType=Decimal) using DAO ( Data Access Objects ), you might have identified your app crashing. If you hover a variable with the type in VBA code, you may see that the field is not being displayed properly; either reading as ‘?????’ or giving a Type Mismatch error, or Access may crash.
    We are very sorry for the inconvenience this causes in your Access app. The Access team is working on resolving this issue as soon as possible, and we will report back to you once this error has been fixed. In the interim, we’d recommend for you to roll back to a previous version ( https://support.microsoft.com/en-us/help/2770432/how-to-revert-to-an-earlier-version-of-office-2013-or-office-2016-clic ), or switch to a slower channel (e.g Monthly Enterprise Channel, or SemiAnnual Channel), until the issue is fixed in Current Channel.  The issue only impacts Decimal types so if avoiding DAO code that manipulates Decimal types is possible, we’d advise this as a short term solution.
    Thank you,
    -Ebo Quansah

    Tuesday, October 6, 2020 1:06 PM