none
Microsoft .Net Framework 3.0 Setup Error RRS feed

  • General discussion

  • I'm using Windows XP Home Edition and I tried to install Microsoft .Net Framework 3.0 (to be able to install 3.5)... anyways I got this error during the installation:

    EventType : wap10setup     P1 : 13165     P2 : 3.0.04506.30_waprtm_x86_sfx    
    P3 : mc     P4 : inst     P5 : f    
    P6 : dd_ca_installxwsregexe_x86.3643236f_fc70_11d3     P7 : 0     P8 : 1603
    P9 : -     P10 : windows communic


    Here are my log files I hope you can help: http://cid-d9ad1ea363cf9d39.skydrive.live.com/self.aspx/.Public/vslogs.cab
    • Changed type YiChun Chen Friday, August 7, 2009 3:09 AM Do not follow up
    Saturday, August 1, 2009 7:34 PM

All replies

  • There are a few things that may be causing this. I can see in the log files errors 1605 and 25007. Try the following to see if it fixes the problem:

    1. Navigate to the %Windir\WinSxS folder (usually C:\WINDOWS\WinSxS)
    2. Delete or rename the Policies folder. It may be a good idea to make a backup of it first in a removable device.
    3. Try installing .NET again.

    See this thread as well about error 25007. There are several other methods in there that may work should this above method not work for you.
    http://social.msdn.microsoft.com/forums/en-US/netfxbcl/thread/47c93410-2ee2-4dd1-812a-04475d50de7c/

    Hope this helps.
    As I said before, I never repeat myself.
    Saturday, August 1, 2009 11:30 PM
  • I did what you said but i still get the same errors in the temp file but i stopped getting the wap10setup error
    Sunday, August 2, 2009 5:37 PM
  • Thank you for Etisoppo's kindly help. :)

    Hi Nick,

    I would suggest you to install .NET Framework 3.5 directly since it includes .NET Framework 2.0 and 3.0.

    Could you please try to use collect tool to collect the log files of .NET Framework 3.5 from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Download .NET Framework 3.5 full package
    - Try to clean your "%temp%" folder
    - Install .NET Framework 3.5 
    - Collect the logs from "%temp%" folder
    - Upload vslogs.cab file

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, August 4, 2009 6:56 AM
  • Hi Nick,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, August 7, 2009 3:09 AM