locked
Questions about VWD 2010 Express RRS feed

  • Question

  • User426001450 posted

    I would like to know if anybody here have heard about any limitation for VWD 2010 Express in handling files to be uploaded to the server using the file upload control. I am trying to upload some picture files and when they are small like 1.5 to 2 MB, I do not have any problem. However, when a picturehas more than 6 or 7 MB, the browser display errors. I am going to paste all the errors displayed with all of the different browser that I tested in order to give you a clear idea of what is going on. I would appreciate your help with this matter. Thanks

    These are the errors: 

    1) With Internet Explorer:

    Internet Explorer cannot display the webpage

    What you can try:

    Diagnose Connection Problems

    More information

    This problem can be caused by a variety of issues, including:
    •Internet connectivity has been lost.
    •The website is temporarily unavailable.
    •The Domain Name Server (DNS) is not reachable.
    •The Domain Name Server (DNS) does not have a listing for the website's domain.
    •There might be a typing error in the address.
    •If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

    For offline users

    You can still view subscribed feeds and some recently viewed webpages.
    To view subscribed feeds: 
    1.Click the Favorites button , click Feeds, and then click the feed you want to view.


    To view recently visited webpages (might not work on all pages): 
    1.Press Alt, click File, and then click Work Offline.
    2.Click the Favorites button , click History, and then click the page you want to view.

    2) With Firefox

    The connection was reset

    The connection to the server was reset while the page was loading.

    The site could be temporarily unavailable or too busy. Try again in a few
    moments.
    If you are unable to load any pages, check your computer's network
    connection.
    If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

    3) Google google chrome


    This webpage is not available

    Less
    The connection to localhost was interrupted.
    Reload this webpage.
    Press the reload button to resubmit the data needed to load the page.
    Check your Internet connection.
    Check any cables and reboot any routers, modems, or other network devices you may be using.
    Allow Chrome to access the network in your firewall or antivirus settings.
    If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.
    If you use a proxy server...
    Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN".
    Error code: ERR_CONNECTION_RESET

    Do anybody here have an idea of what is going on and how to fix this problem? Have any of you experienced or received this message before? If so, what is going on and what should I do?

    Thanks

    Thursday, August 22, 2013 12:38 AM

Answers

  • User2103319870 posted

    The default maximum filesize is 4MB - this is done to prevent denial of service attacks in which an attacker submitted one or more huge files which overwhelmed server resources.

    One suggestion to resolve the issue is to change the size by adding following setting in system.web in web.config.

    Example for 1GB the setting will be

    <system.web>
      <httpRuntime maxRequestLength="1048576" executionTimeout="100000" />
    </system.web>


    Refer this link for more details :

    Large File Upload Issue in File Upload Control

    Large File Upload

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, August 22, 2013 12:50 AM

All replies

  • User2103319870 posted

    The default maximum filesize is 4MB - this is done to prevent denial of service attacks in which an attacker submitted one or more huge files which overwhelmed server resources.

    One suggestion to resolve the issue is to change the size by adding following setting in system.web in web.config.

    Example for 1GB the setting will be

    <system.web>
      <httpRuntime maxRequestLength="1048576" executionTimeout="100000" />
    </system.web>


    Refer this link for more details :

    Large File Upload Issue in File Upload Control

    Large File Upload

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, August 22, 2013 12:50 AM
  • User-1716253493 posted

    Afaik, there is no limitation such that for VWD 2010 in handling files. No deferent your code edited by VWD or VS, its just code.

    The limitation related to your configuration.

    Thursday, August 22, 2013 2:27 AM