locked
Problem with net.framework 3.5 Installation RRS feed

  • Question

  • User1680068183 posted

    Hi,

    Issue: Setting up net.framework 3.5 on my pc.

    Specs: Windows xp Professional sp3.

    When installing i get the following error log,

    [12/26/08,16:37:17] RGB Rast: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [12/26/08,16:37:17] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [12/26/08,16:37:17] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [12/26/08,16:37:17] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [12/26/08,16:37:17] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [12/26/08,16:37:17] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [12/26/08,16:37:18] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [12/26/08,16:37:18] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [12/26/08,16:37:18] WapUI: [2] DepCheck indicates RGB Rast is not installed.
    [12/26/08,16:37:18] WapUI: [2] DepCheck indicates WIC Installer was not attempted to be installed.
    [12/26/08,16:37:18] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a was not attempted to be installed.
    [12/26/08,16:37:18] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
    [12/26/08,16:37:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a was not attempted to be installed.
    [12/26/08,16:37:19] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [01/12/09,21:46:17] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/12/09,21:46:17] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/12/09,21:46:39] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/15/09,16:49:54] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/15/09,16:49:54] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/15/09,16:50:09] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/16/09,17:31:35] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/16/09,17:31:36] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/16/09,17:31:55] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/16/09,18:31:56] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/16/09,18:31:57] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/16/09,18:32:14] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/17/09,10:48:52] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/17/09,10:48:52] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/17/09,10:49:14] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/20/09,11:35:25] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/20/09,11:35:25] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/20/09,11:35:42] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/20/09,11:38:06] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/20/09,11:38:06] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/20/09,11:38:25] WapUI: [2] DepCheck indicates WIC Installer is not installed.

    Monday, January 19, 2009 7:53 PM

Answers

  • User-1492568288 posted

    Sorry for the delay.

    From the logs:

    0.609:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.890: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.890: Condition Check for Line 3 of PreRequisite returned FALSE
    1.000: WIC Setup encountered an error:  Newer version of update is already on the system.
    1.062: Newer version of update is already on the system.
    1.062: Update.exe extended error code = 0xf0f4
    1.062: Update.exe return code was masked to 0x643 for MSI custom action compliance.

    your problem was due to the WIC setup, it found a newer version than the version it attempted to install, you can rename the file C:\WINDOWS.0\system32\WMPhoto.dll and run the .NET Framework 3.0 setup again.

    Also there is a solved issue in MSDN forum: http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/8cce5c65-8c3f-4d13-8800-72e4238d4a04/ please focus on the last post by SavedbyGrace. he was talking about the same problem as yours.

     Thanks.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, January 27, 2009 2:37 AM

All replies

  • User2130758966 posted

     Did a search and seems like this a pretty common problem:

    Have you run all your Windows Updates (and upgraded to Microsoft Update, and kept running it after every reboot until you had got all the patches)?

     

    Once you have installed the asp.net 2.0 then you could use the Microsoft Web Platform Installer to get all your other dev tools up and running:


    Monday, January 19, 2009 8:23 PM
  • User1680068183 posted

     

    Hey, thanx for the reply rtpharry,

    i forgot to mention yes i have installed all my windows updates, except net.framework which the same error occured.

     I did install net.framework 2 and got microsoft web platform running, but one small problem is that, when i go to install net.framework 3.5 sp1 it downloads fine, but when it installs, it installs all they way but doesnt say it has finished. i have left it for hours upon hours at the same install place but it doesnt move nor say it has finished.

    I really appreciate your help.

    Tuesday, January 20, 2009 1:57 AM
  • User1680068183 posted

    hi,

    issue: error installing net framework on windows xp sp3

    i get the following error log:

    [01/20/09,18:48:04] Microsoft .NET Framework 2.0SP1 x86: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [01/20/09,18:48:04] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [01/20/09,18:48:04] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [01/20/09,18:48:04] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [01/20/09,18:48:04] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [01/20/09,18:48:05] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [01/20/09,18:48:05] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [01/20/09,18:48:05] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [01/20/09,18:48:05] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 x86 is not installed.
    [01/20/09,18:48:05] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
    [01/20/09,18:48:06] WapUI: [2] DepCheck indicates WIC Installer was not attempted to be installed.
    [01/20/09,18:48:06] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 x86 was not attempted to be installed.
    [01/22/09,09:27:38] Microsoft .NET Framework 3.0SP1 x86: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [01/22/09,09:27:38] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [01/22/09,09:27:39] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [01/22/09,09:27:39] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [01/22/09,09:27:40] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [01/22/09,09:27:40] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [01/22/09,09:27:40] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [01/22/09,09:27:40] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [01/22/09,09:27:41] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 x86 is not installed.
    [01/22/09,09:37:37] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/22/09,09:37:37] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/22/09,09:37:44] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [01/22/09,10:52:23] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [01/22/09,10:52:23] WIC Installer: [2] Setup Failed on component WIC Installer
    [01/22/09,10:52:31] WapUI: [2] DepCheck indicates WIC Installer is not installed.

    and this is with dd_wic log if needed

    [dd_WIC.txt]
    0.297: ================================================================================
    0.297: 2009/01/12 21:46:16.453 (local)
    0.297: c:\5799d0829492838b1c495bf0a26e09b8\update\update.exe (version 6.3.4.0)
    0.312: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.468: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.609:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.609: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.609: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.609:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.609: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.609: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.609:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.890: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.890: Condition Check for Line 3 of PreRequisite returned FALSE
    1.000: WIC Setup encountered an error:  Newer version of update is already on the system.
    1.062: Newer version of update is already on the system.
    1.062: Update.exe extended error code = 0xf0f4
    1.062: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.390: ================================================================================
    0.422: 2009/01/15 16:49:53.812 (local)
    0.422: c:\5358425b847398e7003e0907\update\update.exe (version 6.3.4.0)
    0.422: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.453: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.515:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.515: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.515: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.515:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.515: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.515: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.515:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.562: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.562: Condition Check for Line 3 of PreRequisite returned FALSE
    0.656: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.718: Newer version of update is already on the system.
    0.718: Update.exe extended error code = 0xf0f4
    0.718: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.329: ================================================================================
    0.344: 2009/01/15 19:29:04.078 (local)
    0.344: c:\148efef2ccf93a026c90aeedf2\update\update.exe (version 6.3.4.0)
    0.344: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.375: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.407:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.407: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.407: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.407:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.407: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.407: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.407:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.438: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.438: Condition Check for Line 3 of PreRequisite returned FALSE
    0.532: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.594: Newer version of update is already on the system.
    0.594: Update.exe extended error code = 0xf0f4
    0.594: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.203: ================================================================================
    0.219: 2009/01/16 15:48:37.296 (local)
    0.219: c:\bd4c4b057ef5ad5ed4288ce6620a\update\update.exe (version 6.3.4.0)
    0.235: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.250: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.281:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.281: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.281: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.281:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.281: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.281: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.297:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.328: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.328: Condition Check for Line 3 of PreRequisite returned FALSE
    0.422: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.500: Newer version of update is already on the system.
    0.500: Update.exe extended error code = 0xf0f4
    0.500: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.422: ================================================================================
    0.437: 2009/01/16 17:18:00.359 (local)
    0.437: c:\7be806fbd30fbd2cdc95dd47\update\update.exe (version 6.3.4.0)
    0.453: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.531: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.547:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.547: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.547: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.547:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.547: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.547: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.562:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.594: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.594: Condition Check for Line 3 of PreRequisite returned FALSE
    0.719: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.812: Newer version of update is already on the system.
    0.812: Update.exe extended error code = 0xf0f4
    0.812: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.218: ================================================================================
    0.250: 2009/01/16 17:31:35.390 (local)
    0.250: c:\dee4ab2c859b3f93dac9014e203121\update\update.exe (version 6.3.4.0)
    0.265: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.312: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.328:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.328: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.328: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.328:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.328: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.328: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.328:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.359: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.359: Condition Check for Line 3 of PreRequisite returned FALSE
    0.453: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.515: Newer version of update is already on the system.
    0.515: Update.exe extended error code = 0xf0f4
    0.515: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.203: ================================================================================
    0.203: 2009/01/16 18:31:56.156 (local)
    0.203: c:\a767b5b342cfe4119822057e9b907bfe\update\update.exe (version 6.3.4.0)
    0.235: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.266: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.281:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.281: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.281: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.281:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.281: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.281: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.281:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.313: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.313: Condition Check for Line 3 of PreRequisite returned FALSE
    0.406: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.469: Newer version of update is already on the system.
    0.469: Update.exe extended error code = 0xf0f4
    0.469: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.141: ================================================================================
    0.172: 2009/01/17 10:48:51.328 (local)
    0.172: c:\29ff2a913d0aa3c609ee\update\update.exe (version 6.3.4.0)
    0.172: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.188: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.235:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.235: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.235: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.235:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.235: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.235: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.235:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.282: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.282: Condition Check for Line 3 of PreRequisite returned FALSE
    0.422: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.500: Newer version of update is already on the system.
    0.500: Update.exe extended error code = 0xf0f4
    0.500: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.453: ================================================================================
    0.453: 2009/01/20 11:35:24.734 (local)
    0.453: c:\1b4ea3a2bbda662eb5673254\update\update.exe (version 6.3.4.0)
    0.469: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.485: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.516:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.516: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.516: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.516:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.516: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.516: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.516:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.563: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.563: Condition Check for Line 3 of PreRequisite returned FALSE
    0.641: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.719: Newer version of update is already on the system.
    0.719: Update.exe extended error code = 0xf0f4
    0.719: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.344: ================================================================================
    0.344: 2009/01/20 11:38:05.750 (local)
    0.344: c:\4c9d69572dab073112a06f08ef\update\update.exe (version 6.3.4.0)
    0.344: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.375: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.391:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.391: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.391: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.391:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.391: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.391: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.391:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.422: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.422: Condition Check for Line 3 of PreRequisite returned FALSE
    0.531: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.594: Newer version of update is already on the system.
    0.594: Update.exe extended error code = 0xf0f4
    0.594: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.281: ================================================================================
    0.312: 2009/01/20 14:10:14.109 (local)
    0.312: c:\819bde1fbee51ac3fd3b\update\update.exe (version 6.3.4.0)
    0.312: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.375: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.422:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.422: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.422: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.422:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.422: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.422: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.437:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.531: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.531: Condition Check for Line 3 of PreRequisite returned FALSE
    0.609: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.703: Newer version of update is already on the system.
    0.703: Update.exe extended error code = 0xf0f4
    0.703: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.297: ================================================================================
    0.313: 2009/01/20 15:55:16.593 (local)
    0.313: c:\a648301c200a0fec44df4b40801bfc\update\update.exe (version 6.3.4.0)
    0.313: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.344: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.360:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.360: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.360: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.360:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.360: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.360: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.360:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.391: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.391: Condition Check for Line 3 of PreRequisite returned FALSE
    0.485: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.563: Newer version of update is already on the system.
    0.563: Update.exe extended error code = 0xf0f4
    0.563: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.156: ================================================================================
    0.172: 2009/01/22 09:37:37.375 (local)
    0.172: c:\972cabcf3d108f3bfad3e0744a5ca30e\update\update.exe (version 6.3.4.0)
    0.172: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.188: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.188:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.188: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.188: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.188:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.188: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.188: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.188:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.235: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.235: Condition Check for Line 3 of PreRequisite returned FALSE
    0.313: WIC Setup encountered an error:  Newer version of update is already on the system.
    0.375: Newer version of update is already on the system.
    0.375: Update.exe extended error code = 0xf0f4
    0.375: Update.exe return code was masked to 0x643 for MSI custom action compliance.
    0.563: ================================================================================
    0.578: 2009/01/22 10:52:22.531 (local)
    0.578: c:\ded011ecb7caf607a11d0a6a1c1a1c\update\update.exe (version 6.3.4.0)
    0.578: Hotfix started with following command line: /quiet /norestart /log:C:\DOCUME~1\Designer\LOCALS~1\Temp\dd_WIC.txt
    0.656: In Function GetBuildType, line 1170, RegQueryValueEx failed with error 0x2
    0.750:  C:\WINDOWS.0\system32\WindowsCodecs.dll is Not Present
    0.750: First Condition in Test.WindowsCodecsVer.Section Succeeded
    0.750: Condition succeeded for section Test.WindowsCodecsVer.Section in Line 1 of PreRequisite
    0.750:  C:\WINDOWS.0\system32\WindowsCodecsExt.dll is Not Present
    0.750: First Condition in Test.WindowsCodecsExtVer.Section Succeeded
    0.750: Condition succeeded for section Test.WindowsCodecsExtVer.Section in Line 2 of PreRequisite
    0.766:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.891: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.891: Condition Check for Line 3 of PreRequisite returned FALSE
    1.016: WIC Setup encountered an error:  Newer version of update is already on the system.
    1.094: Newer version of update is already on the system.
    1.094: Update.exe extended error code = 0xf0f4
    1.094: Update.exe return code was masked to 0x643 for MSI custom action compliance.

    appreciate any help or reply.

    Wednesday, January 21, 2009 6:59 PM
  • User-1492568288 posted

    Can you please use the tool mentioned here: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx to collect installation log files and upload to upload server, paste the link here so that we can diagnose it later.

    Thanks.

    Thursday, January 22, 2009 3:02 AM
  • User1680068183 posted

     

    Hi, Thank you very much for your reply Figo Fei i appreciate your help so much.

    http://files.filefront.com/NetFramework+Log+Fileszip/;13055380;/fileinfo.html

    There's all the log files it told me to get, thats the link if that doesnt work you can go here: http://hosted.filefront.com/transe/ and click on Net Framework 3.5 Log files.

    thanks alot.

    Thursday, January 22, 2009 5:09 AM
  • User-1492568288 posted

    Sorry for the delay.

    From the logs:

    0.609:  C:\WINDOWS.0\system32\WMPhoto.dll is Present
    0.890: FileVersion of C:\WINDOWS.0\system32\WMPhoto.dll is Greater Than 6.0.5840.16388
    0.890: Condition Check for Line 3 of PreRequisite returned FALSE
    1.000: WIC Setup encountered an error:  Newer version of update is already on the system.
    1.062: Newer version of update is already on the system.
    1.062: Update.exe extended error code = 0xf0f4
    1.062: Update.exe return code was masked to 0x643 for MSI custom action compliance.

    your problem was due to the WIC setup, it found a newer version than the version it attempted to install, you can rename the file C:\WINDOWS.0\system32\WMPhoto.dll and run the .NET Framework 3.0 setup again.

    Also there is a solved issue in MSDN forum: http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/8cce5c65-8c3f-4d13-8800-72e4238d4a04/ please focus on the last post by SavedbyGrace. he was talking about the same problem as yours.

     Thanks.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, January 27, 2009 2:37 AM
  • User1680068183 posted

     

    Thank you so much!!!!!!!!!!!!!!!! renaming the file made 3.0 and 3.5 work thank you!!!!!!!!!!!!!!!!w000tttt
    Tuesday, January 27, 2009 3:47 AM
  • User997519954 posted


    hi people...im having a problem here installing the .net framework 3.5...i've already tried to reinstall from the version 1.0 but seems to have the same problem...heres the error log

    [09/07/09,05:36:26] WIC Installer: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [09/07/09,05:36:26] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [09/07/09,05:36:26] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [09/07/09,05:36:26] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [09/07/09,05:36:26] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [09/07/09,05:36:26] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [09/07/09,05:36:27] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [09/07/09,05:36:27] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [09/07/09,05:36:27] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [09/07/09,05:36:27] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a was not attempted to be installed.
    [09/07/09,05:36:27] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
    [09/07/09,05:36:27] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0a was not attempted to be installed.
    [09/07/09,05:36:28] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [09/07/09,05:36:28] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5LP - ESN was not attempted to be installed.
    [09/07/09,20:52:29] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
    [09/07/09,20:54:33] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
    [09/08/09,05:42:56] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
    [09/08/09,05:44:47] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.
    [09/08/09,15:05:33] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
    [09/08/09,15:07:23] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.


    so i hope you can help me with this guys cuz is really a headache XD

    Wednesday, September 9, 2009 3:19 PM