locked
Blob Containers Error Acces - Microsoft Azure Storage Explorer RRS feed

  • Question

  • Hello all,

    I've installed Microsoft Azure Storage Explorer on a windows serveur 2012 R2.

    When i configure an External Storage with correct "storage account name" and correct primary or secondary key. Impossible to see containers & file under "Blob Containers" menu. I got error :

    If i test with other soft like Cloudberry ou CloudXplorer no problem with same storage account & key.

    Did someone had an idea about the problem ?


    • Edited by Mawelou Wednesday, April 13, 2016 7:18 AM
    Wednesday, April 13, 2016 7:16 AM

All replies

  • Hi,

    Thanks for posting here.

    I suggest you to refer the below link for more details.

    https://www.petri.com/using-the-microsoft-azure-storage-explorer-tools

    Hope this helps.

    Girish Prajwal

    Wednesday, April 13, 2016 8:18 PM
  • Hi,

    I already use tools like that, but the problem, is when i configure it with the right name/url & key impossible to list under it the containers or file in the blob part of the tool.

    In other tool not free, i got access whitout any problems... that's why I tried to understand, what's wrong and why i got this error.


    Réponses TechNet

    Thursday, April 14, 2016 7:32 AM
  • Hi,

    When you say External Storage - Which storage you are referring to here?

    Is it not Microsoft Storage account?

    Girish Prajwal

    Thursday, April 14, 2016 7:03 PM
  • Hi,

    I mean, Microsoft Storage Account (Called "External Storage...")

    


    Réponses TechNet

    Friday, April 15, 2016 7:11 AM
  • Hi there,

    The behavior you have seen is certainly not by design. I want to check on couple of things with you:

    1. You have downloaded the tool from storageexplorer.com and it's the latest release (build 20160325.1).

    2. If this is the tool you are using, when attaching external storage accounts, we currently don't support attaching to a secondary Read-only Geo Replicated storage account (RA_GRS). You will need to use the primary account.

    3. Make sure you select the correct endpoints for your storage account under "Storage endpoints domain:".

    Other than these, did the error you saw only happen with this particular storage account or you basically couldn't attach to any external storage?  Have you also tried to attach using a SAS key (make sure you have at least the "read" and the "list" permission when generating the SAS key. We need the "list" permission to be able to display the contents in the blob containers.

    Could you please confirm or answer the questions so I can try to help a bit more?

    Thanks.


    Wednesday, April 20, 2016 11:15 PM
  • Hi, 

    thanks to take time to answer me.

    So :

    1. Yep i've installed the release from storageexplorer.com as you can see below 

    

    2. It's a normal local replicated storage account, and i always use the primary key.

    3. By default good endpoint domain, i'm under North Europe storage.

    i've tried to with SAS and same problem


    Réponses TechNet

    Friday, April 22, 2016 7:44 AM
  • Hello,

    Did you try an older version to see if there is a bug in the software ?

    https://github.com/Azure/deco/releases

    I'm using this version and is working fine for me.

     As workaround

    best Regards,
    @Jamesvandenberg

    Friday, April 22, 2016 9:24 AM