locked
Cannot create a connection to data source 'DataSource1' RRS feed

  • Question

  • User-1312722619 posted

    I can successfully run a sample report on the local computer. DataSource and Report are valid it renders perfect.

    But when i move my DataSource and Report to Remote server which is hosted by a company, then i always receive following error!. It is really disgusting. Do you have any idea whys that for?

     

    • An error occurred during client rendering.
      • An error has occurred during report processing.
        • Cannot create a connection to data source 'DataSource1'.
          • For more information about this error navigate to the report server on the local server machine, or enable remote errors

     

    Sunday, January 16, 2011 11:04 AM

All replies

  • User-1412735316 posted

    please add folloiwng lines to web.config to get the actual error message.

    <configuration>
    <system.web>
    <customErrors mode="Off" />
    </system.web>
    </configuration>

    Now please let me know which kind of datasource configuration you are using? is it "Windows Integrated Security" or you are using sqlserver user with password.
    Please clarify me so that i can try my best to help you.
    Sunday, January 16, 2011 11:58 AM
  • User-1312722619 posted

    Hi,

    Thanks for your response.

    web.config has nothing to do with this issue, because i use Report Manager now just to make sure it is working or not.

    My DataSource is bind to a remote server database, either when i run the report on my local computer or when i run on the report manager of the hosting company. 

    Sunday, January 16, 2011 12:09 PM
  • User-1412735316 posted

    Actualy i never faced this problem before. But trying to find you a solution. I have requested the actions just to see the actual inner exception.

    Hope you have checked the connectivity between your hosting and database server. At this moment i m reading some such isssues and trying to figure out actual solution.


    Sunday, January 16, 2011 1:10 PM
  • User-1312722619 posted

     Hi,

    Sorry for confussion. My hosting company informed me that i am trying to access to another server which is not hosted by them. It is resolved.

    Thanks for your support.

    Sunday, January 16, 2011 2:40 PM
  • User-1412735316 posted

    nice to hear.

    Sunday, January 16, 2011 2:59 PM
  • User1471008070 posted

    Hi,

    Since you solve the issue by yourselft, could you please share the solution with us, I could mark it as answer, then other members who encounter the same issue will know the right direction. 

    Thanks,
    Challen Fu 

    Monday, January 24, 2011 8:29 AM
  • User-1312722619 posted

    just commercial isues.. the hosting company i use my report server allow me to connect to only databases which is served by them. they send me this information and issue resolved. Because i paid for a database to which i connect succesfully.

    Thursday, January 27, 2011 3:12 PM