locked
this app failed to launch because of an issue with its license

    Question

  • this app failed to launch because of an issue with its license

    I've been working on this game for quite some time now, getting close to it's end.  But this morning I tried building my game and I'm getting this error.

    I do know last night I tried to shut down my PC 3 times before I realized my project was still open on the desktop app.

    Tuesday, October 30, 2012 12:57 PM

Answers

All replies

  • Having the same issue as of this morning...

    I am not sure why the connect issue is closed (what is the external status?), but the workaround is to uninstall the app and redeploy:

    http://connect.microsoft.com/VisualStudio/feedback/details/768770/cant-run-windows-store-app

    I don't like workarounds though - doesn't actually get to the cause of the issue!

    • Edited by Jono Stewart Wednesday, October 31, 2012 6:06 PM
    • Marked as answer by DualOpAmp Wednesday, October 31, 2012 7:22 PM
    Wednesday, October 31, 2012 6:03 PM
  • Yep, I figured it out. Not to long after posting this.  Thanks.

    Wednesday, October 31, 2012 7:22 PM
  • I also received this error on one of my projects.  If I get this error, and click on HELP, I'm directed to
    http://msdn.microsoft.com/query/dev11.query?appId=Dev11IDEF1&l=EN-US&k=k(vs.debug.error.app_activation_failure)&rd=true

    However, this page does not mention the workaround of simply uninstalling the app via the start screen.  Only 1 of out 56 people rated that page as being helpful.

    I hope Microsoft will:

    1) Uncover the CAUSE of the problem, and fix it in the next few months.

    2) Improve the documentation at the link above to handle this situation.

    3) Change the policy which allows problems to be CLOSED without being resolved. 

    Details of error:

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" /> 
      <EventID>5974</EventID> 
      <Version>0</Version> 
      <Level>2</Level> 
      <Task>5974</Task> 
      <Opcode>0</Opcode> 
      <Keywords>0x4000000000000000</Keywords> 
      <TimeCreated SystemTime="2012-11-21T01:04:49.301695900Z" /> 
      <EventRecordID>3670</EventRecordID> 
      <Correlation /> 
      <Execution ProcessID="4688" ThreadID="6008" /> 
      <Channel>Microsoft-Windows-TWinUI/Operational</Channel> 
      <Computer>AVA-363986</Computer> 
      <Security UserID="S-1-5-21-1215559615-4072840042-3781464165-1001" /> 
      </System>
    - <EventData>
      <Data Name="AppId">e671ed15-88ac-49cb-9b82-4d03f743cf5c_yqdhsn7yvy3k6!App</Data> 
      <Data Name="ContractId">Windows.Launch</Data> 
      </EventData>
      </Event>

    • Edited by Andrew7Webb Wednesday, November 21, 2012 6:08 PM add error images
    Wednesday, November 21, 2012 5:59 PM
  • I solved it by moving the project folder to another place.
    Wednesday, November 21, 2012 7:10 PM
  • I solved it by clicking this check box:

    I'm guessing test apps have a time bomb in them, and it's not until you really publish the app that you can run it forever...

    • Proposed as answer by jacobandgeckos Thursday, January 03, 2013 12:49 AM
    • Unproposed as answer by jacobandgeckos Thursday, January 03, 2013 12:49 AM
    Monday, December 24, 2012 3:50 AM
  • Where is that check box?
    Sunday, March 10, 2013 7:21 PM
  • James,

    You can find this check box by 1) right click on the project, 2) select properties, 3) click on the Debug section, and 4) check the box. That should be it.

    I was hitting this a few times and this fixed it.

    Wednesday, April 03, 2013 3:23 AM
  • I was looking for te license, and found no dates or other things.

    Instead I downloaded a new sample to a new directory and it works.

    So when you renew a license, also download the files to a new directory.

    Friday, April 19, 2013 3:24 AM