locked
Unreliable Public/Private DNS in Private Network with Domain Controller RRS feed

  • Question

  • I have setup a virtual network with 4 VM's.  All are running Server 2012, with one of these VM's being a domain controller and the other 3 being domain members.  

    In my virtual network settings in Azure I have added a DNS server which is the IP address of my DC (10.0.0.5).  If I leave this as the ONLY DNS server defined, name resolution within the virtual network/domain works perfectly.  However, getting out (to a public website for example) is slow and unreliable (sometimes never works).

    I then experimented by adding a Public DNS server (8.8.8.8 - Google's public DNS) to the virtual network settings in Azure.  When I do this, getting out to public websites is very fast and works perfectly, but the internal network/domain name resolution is sporadic - it works for a while and then just quits.  

    I've been battling this for a week and have no idea what to try or what would cause this.  Any suggestions would be greatly appreciated!  Thanks,

    -Jason

    Thursday, July 11, 2013 9:38 PM

Answers

  • Hi,

    If you try it sooner than that and it doesn't work, try "ipconfig /flushdns". It should never be more than, say, five minutes. (I think it should always be significantly less.)

    And I suggest you configure a DNS server to use forwarders using the Windows interface, Please refer to the following article:

    Configure a DNS Server to Use Forwardershttp://technet.microsoft.com/en-us/library/cc754941.aspx

    Hope it helps!

    Thursday, July 18, 2013 9:25 AM

All replies

  • Hi,

    If you try it sooner than that and it doesn't work, try "ipconfig /flushdns". It should never be more than, say, five minutes. (I think it should always be significantly less.)

    And I suggest you configure a DNS server to use forwarders using the Windows interface, Please refer to the following article:

    Configure a DNS Server to Use Forwardershttp://technet.microsoft.com/en-us/library/cc754941.aspx

    Hope it helps!

    Thursday, July 18, 2013 9:25 AM
  • This, along with putting adding the DC's DNS & an external, public DNS into the network settings for each member computer seemed to do the trick.  Thanks!
    Tuesday, July 23, 2013 1:19 PM