locked
Problem with submitting Windows 10 Mobile app RRS feed

  • Question

  • Hi,

    Microsoft rejected our app update 3 times after we added support for Windows 10 Mobile with a message that it cannot be installed on Windows 10 Mobile, but we checked this version on emulator and every piece of Windows Mobile device that we have in our company and it works all fine (e.g. Lumia 735, Lumia 830, Lumia 640XL). I am uploading it through device portal and got no problems at all. How are you doing the upload to device? If you tell me, I would be able to check same way by my side, and maybe I will find this error. I am really looking forward for some feedback, because without it I will be unable to make my app available on your platform.

    Maybe you are trying to install it on older version of Windows Mobile? Our current requirements is Anniversary Update: Windows.Universal min version 10.0.14393.0

    Best regards,
    Tomasz Wartalski

    Thursday, October 12, 2017 7:53 AM

All replies

  • Good luck with getting an answer.  I have been dealing with this exact same problem since October 4 with no meaningful response from Microsoft.  I have made two submissions with the results: Installs on Desktop; Does not install on Mobile.  

    Since I have it installed on two physical devices, a Lumia 750 XL and a Lumia 635, along with a number of the Mobile emulators, I questioned their conclusion and asked for specifics in a message over a week back (part of their unhelpful reply is copied at the end of this) and a second more recent message to which I have received no reply.

    I think something is not function at the Dev Center as regards our submissions.  In fact, when I just went to the Dev Center and clicked on the link to see my apps Report again, the Report is not produced.  

    Their response: Hello William,
    I understand you are experiencing issues with your app submission and it's certificaiton results.  For further reviewn you can follow up using the certification results by directly responding using the feedback section.  As it turns out this would be outside of our support realm, but i have included support contact(s) whom which can better assist you.  You can contact Visual Studio Support or you may feel free to use our technical forums so our moderators, and potentially other developers, may assist in troubleshooting further and resolving this issue. Alternatively, you may seek paid technical support by going here and selecting the needed options under the "App Development," section. For example "Windows 10 universal app development."

    Thursday, October 12, 2017 5:19 PM
  • Hi Tomasz,

    As far as I'm concerned, the failure report should include the detailed info of device tester used to test your app. You might check it and try to install your app on that device model.

    You might also try to reduce the min version supported by your package in case that the tester test your app on device with lower version.

    If the issue still persists, please contact Windows Store team at reportapp@micorosoft.com as it's hard to detect the specific cause without seeing your app in forum.

    Thank you.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, October 13, 2017 8:20 AM
  • Hi Mattew,

    I send an email to reportapp@micorosoft.com four days ago and still didn't get any answer and from what I can see I am not the only one with exact same issue. How long it usually takes to get some answer?

    Regards,
    Tomasz Wartalski

    Friday, October 13, 2017 9:49 AM
  • Thank you for sharing. You are right - we have the exact same problem and I get the exact same answer from Microsoft. If you'll manage to get some answers or workaround please share it here (I'll do the same).

    Thank you,
    Tomasz Wartalski

    Friday, October 13, 2017 9:52 AM
  • I have received a response from Microsoft!

    Below is the message I received about my app failing for Win Mobile (but OK for the Desktop).  Below that is a screen capture of the targeting for my app in Visual Studio.  Looks fine to me, and it is the same as for a UWP app submitted a couple months back.  And here is link to Microsoft's instructions on choosing a UWP version.  They mention a build 16299 as the latest version of Win 10, which I have not seen.  And my computer claims to have the latest update.  https://docs.microsoft.com/en-us/windows/uwp/updates-and-versions/choose-a-uwp-version

     

    Do you see anything wrong with all this?  Is it possible the minimum version is too low?

     

     

    Hello Developer,

     

    We have received your feedback from Dev Center for "Old Tampa Photos" and we have provided some additional information for you below.

     

    The app does not install on mobile devices however installs as expected on desktop. Please update the targeted platforms and resubmit the app for certification where it will be reviewed.

     

    Please let us know if you need any additional assistance.

     

    Thank you,

    Irina

    Windows Store Team

     

     

    Here is a screen capture of my targeted OS

     

    Friday, October 13, 2017 2:09 PM