none
Unable to create Word automation in Win 2008 R 2 Or rather Word doc 'vanished' RRS feed

  • Question

  • Sorry I am not sure I got the correct forum right. This seems to be the best I can choose. I am aware that Office is not supported to be automated in any server/service applications. However, I have started this project before stumbling on this project and therefore I have to complete the project. The problem is not automation per se but Win 2008

    I may be wrong on this and therefore I am open to corrections and fresh ideas. First let me tell you what I am trying to do. I want to generate series of Word docs, send them to some email boxes as email attachment, after this is accomplished, send SMS to the people concerned that the task is accomplished and they should check their mails. It is working on the development box (Win XP).

    I now moved it to the production server (Win 2008 R2, Standard). When I tested it, I did NOT see the expected mails, neither was SMS seen. I am fairly sure the documents were generated, but it was as if they vanished. I came to this conclusion because in the course of it being generated, some records in a table were correctly manipulated.

    To accomplish this task, I created a DLL. In order for this DLL to have access to the requested tables and folders, I used appPool(I created one with LocalSystem). My understanding is that this is a very special account that is very powerful, and has access to all files and folders.

    To create the document, of course I have to use CreateObject. To send the mail, I have to use CreateObject. To send the SMS, I need to use RESTful API, still using CreateObject. None of these seems to 'work', they seem to work but I am not seeing the result. Though I have not confirmed, it seems the credit was reduced, so the SMS must have been sent. I checked Event View. No error was generated. I think there is one or two switches that I need to flip. I wanted to manipulate Component Service to give it Launch and Activation Permission, but somehow I am unable to do this. The CLS of Word was not listed. What do you think I am doing wrong? Thanks a lot.


    Sunday, September 29, 2013 2:12 PM