locked
App has become unresponsive and has been terminated.

    Question

  • I have run my app for hours on end but cant get it to crash.

    Ms tell me that the touch input is causing a crash but I cant get it to go wrong on Windows 8 touch simulator.

    What to do next ?


    n.Wright

    Tuesday, October 1, 2013 9:34 PM

Answers

All replies

  • Take a look at the crash report you should have received with the certification failure. See Matt's blog entry Dump Diving into Cert Failure:  How to Get a Good Callstack from TriageDump.dmp   

    You might also want to test on Windows 8 rather than on Windows 8.1 in case the behavior is different.

    --Rob

    Tuesday, October 1, 2013 11:51 PM
    Owner
  • If I load in the triage dump then VS2013 gives me a stack.

    All this tells me is a thread got stuck.

    I simply took a MS simplesample example and expanded that for my purposes and took out code I didn't need.

    I do have some async functions but they don't run while the game is playing which is when it goes wrong.

    I do have fast PC so perhaps the code is hanging on a slow machine.

    I tried running my PC at 800MHz but it still doesn't crash.

    MS also suggested it was a problem with touch input but running Win 8 touch simulator doesn't crash the software.


    n.Wright

    Wednesday, October 2, 2013 12:43 AM
  • I tried VS2012 and my app on a 1GHz laptop and it doesn't crash so it cant be a speed problem.


    n.Wright

    Wednesday, October 2, 2013 11:03 PM
  • The problem was with loading in sound files.

    However I fixed it and put it back in for certification and I am told it still hangs although the tester has got further into the game.

    Using wack3.1 obviously helps to get so far but not having the hardware/software MS have makes it difficult to locate problems.


    n.Wright

    Monday, October 7, 2013 5:05 PM