locked
How to add 'Data Driven Test Results' to 'Test Result Details' window for automated testing RRS feed

  • Question

  • Hi, last time I was running remotely Coded UI Test (using physical environment) and I have problem with the returned results from these tests. When after test I double-click on failed Test Case in 'Test Results' tab and 'Test Result Details' window opens there is not section called 'Data Driven Test Results' as below:

    But when launching the same tests locally by Visual Studio and do the same operations - in 'Test Result Details' there is 'Data Driven Test Results' and I can see what was wrong, example below:

    How can I add 'Data Driven Test Results' to 'Test Result Details' window for automated remote testing?

     




    • Edited by zbiko Thursday, May 12, 2011 8:11 AM
    • Moved by Mathew Aniyan MSFT Wednesday, June 8, 2011 4:16 AM Problem with Test Infrastructure. (From:Visual Studio UI Automation Testing (includes CodedUI))
    Monday, May 9, 2011 10:30 PM

All replies

  • Additionally, just I checked that if I run tests and I DON'T add test data from XML file (I did it as described this blog: http://blogs.msdn.com/b/mathew_aniyan/archive/2009/03/17/data-driving-coded-ui-tests.aspx) - everything is working properly, as below:


     

    There is the error message box and I can see there what was wrong.

    So how should I solve my problem that  work properly displaying the results for remote testing using XML file with test data.

     

    Thanks in advance for any help!!!





    Tuesday, May 10, 2011 1:12 PM
  • Have you any ideas?? It is very important for me.
    Monday, May 16, 2011 9:08 AM
  • Please wait some time before opening the test results. The test results need to be transmitted from Agent to Controller & then to the TFS server. Check the test results now and verify that you don't see the results for all iterations.

     

    If you still are not able to see the results of data iterations, please add a TestContext.Writeline with the data value at the end of each coded ui test method and check that these values are showing up in the test results.

    Monday, May 16, 2011 1:49 PM
  • Ok, so:

    I was wating before opening the test results even five minutes and didn't help - after this I've refreshed window in Test Manager 2010 and open attachment "tmiResult.tr_" I have the same problem.

     

    I also added TestContext.Writeline() after "this.UIMap.AssertMethod1();" line and every time when asserts passed correctly I got the message, as below:

    So partially I can solve my problem by displaying the expected and current results for each row before asserts but how can I solve problem with display exceptions???

    Have you any ideas and what else can I do with it?

     

     

    Thanks in advance for your help.



    Tuesday, May 17, 2011 2:02 PM
  • Which version of Visual Studio/Test Agent/Controller are you using? I vaguely recollect that there were some issues in data driving on remote machines that was fixed in Visual Studio 2010 RTM version.

     

    By adding the WriteLine, i wanted to verify that the test was indeed iterating through the data source. The results seem confusing to me. In your earlier screenshot, you had three iterations. But in the last screenshot, you only have two iterations. Please include the data value as part of the WriteLine.

     

    What type of data source are you using? If it is an XML file, have you made it a deployment item so that it available at the remote machine.

    Wednesday, May 18, 2011 2:28 AM
  • Hi,

    I have Visual Studio 2010 Ultimate version 10.0.30319.1 RTMRel, Test Controller version 10.0.31118.1 and Test Agent version 10.0.30319.1 with Feature PAck 2 on it ( http://msdn.microsoft.com/en-us/library/gg269474.aspx )

     

    Everythig is good becasue in last example there are three iteration (two good and one with incorrect result). I added " TestContext.Writeline("Testowy message"); " after sections of asster so in one case I have one screenshot but I haven't "Testowy message" in Addition Inforamtion box for it.

     

    I use XML files and always they are available at the remote machine.

     

    I do not know how I can fix it..


    Wednesday, May 18, 2011 9:02 AM
  • Hi,

    Can you please test with a simple Data Driven Unit test?

    Please let us know if you have the same results or not.

    Thank you ~Teddy

    Sunday, May 22, 2011 4:38 AM
  • Closing this thread since there is no response.
    • Marked as answer by Mathew Aniyan MSFT Monday, May 30, 2011 10:06 AM
    • Unmarked as answer by zbiko Tuesday, June 7, 2011 12:58 PM
    Monday, May 30, 2011 10:06 AM
  • Hi all, sorry for delay.

    I was running the most simple data driven unit test and I got the same result as for the coded UI test. So where should I look for solution of problem?


    Thanks in advance for any help!!!


    Tuesday, June 7, 2011 1:13 PM
  • May be I wrong deployment xml files. How should I do it? By 'Local.testsettings' or 'TraceAndTestImpact.testsettings'? And which version of xml file add there? These from local source or from publish?


    Tuesday, June 7, 2011 2:46 PM
  • What is interesting is that the problem occurs at the time when I add the xml file to the project (even before attaching the data from xml file to variables or controls) and with remote start.

    Wednesday, June 8, 2011 9:36 AM
  • This is still an issue in Visual Studio 2010 SP1.

    If run a simple XML data-driven unit test (grab a row Id and return success) locally, I get detailed results that include the Data Driven Test Results section.

    If I run the same unit test on a remote machine (through VS2010, with test controller and agent on the same remote machine), I get the Common Results section, but no Data Driven Test Result section.

    The test (and the unsimplified version) iterates through the data rows just fine, whether it's on my local machine or the remote machine.

    Friday, May 10, 2013 8:28 PM
  • And as soon as I post this, I find the answer elsewhere...

    (can't link yet...)

    social.msdn.microsoft.com/Forums/en-US/vsunittest/thread/8964cf6c-3df3-483a-aa3f-95edff70e9af

    Running the VS2010 SP1 installer on the controller/agent machine resolved the issue.

    • Proposed as answer by MerrellM Friday, May 10, 2013 9:16 PM
    Friday, May 10, 2013 9:16 PM