none
Debugger does not always start

    Question

  • I recently moved my VS 2010 development environment to a new computer running Windows 10. Since then, I have noticed that frequently, the debugger will not start and the only way to test my web application(s) is to press [Ctrl][F5] to start without debugging. Moments later I will try again and the debugger will indeed start.

    When this happens, I see that the build was successful, and the local IIS port message displays and then the screen flashes, and finally, execution stops. Sometimes, simply launching the debugger again will get start it up. Other times, I've tried doing a clean and rebuild and the debugger will start but not always.

    It is extremely inconsistent and sometimes, when I really need to debug I can't get it started.

    Is this a condition of VS 2010 on Windows 10? My VS environment is at service pack 1.

    Any help our advice on this issue would be most appreciated.

    Thanks!

    Bob

    Thursday, December 31, 2015 4:09 PM

Answers

  • Okay, it seems like the Super-Shield protection app is causing the issue. Suspending this protection while debugging seems to be consistently solving the problem.

    Thanks for the suggestion Jack.

    • Marked as answer by BobHIll Tuesday, January 05, 2016 6:27 PM
    Tuesday, January 05, 2016 6:27 PM

All replies

  • Hi Bob,

    >>Is this a condition of VS 2010 on Windows 10? My VS environment is at service pack 1.

    If you create a simple web app, could you debug it in your VS2010?

    Please close all third party tools like the Anti-virus or others, and then re-debug your app again.

    Please reset your VS settings, so we could know that whether it works well using the default settings:

    https://msdn.microsoft.com/en-us/library/ms247075(v=vs.100).aspx

    Please disable the "Enable Visual Studio hosting process" in your project property. Someone met one issue is that it would locked the project files if he enabled this option. So you could disable and debug it again.

    If still no help, and all web apps have the same issue, I suggest you repair your VS.

    But if just the specific one has this issue, please create a blank solution, add all project files to the new blank solution, clean and build the new solution, debug it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, January 01, 2016 9:07 AM
    Moderator
  • I hadn't even thought of anti-virus software. I disabled my Super-Shield app and was able to start the debugger. This might just be a coincidence but I'll see if this solves the problem.
    Monday, January 04, 2016 3:28 PM
  • Hi Bob,

    >>I disabled my Super-Shield app and was able to start the debugger. This might just be a coincidence but I'll see if this solves the problem.

    If you get any latest information, please feel free to let me know. Of course, if it really resolves this issue after you disabled the Super-Shield app, you could make the useful reply as the answer.

    Have a nice day,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, January 05, 2016 2:03 AM
    Moderator
  • Okay, it seems like the Super-Shield protection app is causing the issue. Suspending this protection while debugging seems to be consistently solving the problem.

    Thanks for the suggestion Jack.

    • Marked as answer by BobHIll Tuesday, January 05, 2016 6:27 PM
    Tuesday, January 05, 2016 6:27 PM