none
Bug: Azure AWS gallery app for SSO integration does not save SSO choice

    Question

  • While following the "Tutorial: Azure Active Directory integration with Amazon Web Services (AWS)", I discovered that the step 2 of "Configure Azure AD single sign-on" section - doesn't work. Specifically the choice of "SAML" is never saved. Instead, it always reverts back to disabled (there is no "Save" button either). If you were to follow the guide as is, when you'd click "Test", you would be greeted by this error message: "This functionality is not enabled or not available".

    The work-around is to switch to do the relevant setup, then switch to the "old experience" and click save. That enables SAML finally.

    Saturday, January 12, 2019 12:08 AM

All replies

  • We tried to repro the scenario on our end, and were able to successfully deploy the AWS Web Services application:

    1. When we tried to change the URL for the SAMLM Sign-On, we were able to successfully Save the changes

    2. On using the Test this application feature, we got the option to continue as the Current User or Use Another Account. We chose to continue as the same logged in User and were redirected to the AWS Services Website as well.

    Kindly, check again on your end and provide Screenshot if possible.

    Monday, January 14, 2019 10:27 AM
    Moderator
  • Hi,

    See this image: https://pasteboard.co/HWrurJ3.png if you start with the single-sign on mode and click SAML, it won't save as it doesn't have a save button.

    Monday, January 14, 2019 6:25 PM
  • The screenshot that you have shared is from the OverView of the Single Sign-On settings. On the "Basic SAML Configuration" you would see the little "pencil" icon to change the settings. Then once you make changes, the Save Button would be visible.

    Wednesday, January 16, 2019 10:15 AM
    Moderator