locked
MSDN Library for Visual Studio 2008. No Table of Contents or Index

    Question

  • I installed VS2008 RTM.  After this was complete I installed the MSDN library that came on the disk.  When I start VS2008 and try to display a Table of Contents or Index I get "No table of contents has been defined...." or "No index has been defined.....".  I get this in either VS2008 or the Document Explorer.  I can however do a search and get results.

     

    Any help would be great!

     

    Dan

    Sunday, November 25, 2007 2:47 AM

Answers

  • Hi Dan,

     

    It looks like Help merge is broken on your machine.

    If you have any other documentation for example WinSDK etc you might have to re-install after running these steps

     

    1. Rename your Help folder at C:\Program Files\Common Files\Microsoft Shared\Help

    2. Rename your Help 9 folder at C:\Program Files\Common Files\Microsoft Shared\Help 9

    3. Rename nslist.hxl file at C:\Documents and Settings\All Users\Application Data\Microsoft Help

    3. Go to Add\Remove program and run repair on Microsoft Document Explorer 2008

     

    I hope this will fix your broken help experience.

     

    Thanks 

     

    Friday, November 30, 2007 12:36 AM
    Moderator

All replies

  • Isn't there anyone from Microsoft monitoring this?  Have you heard of this problem or am I the only one with this issue?

     

    Any response would be nice

     

    Dan

     

    Wednesday, November 28, 2007 2:25 AM
  • Dan,

    Sorry about the delayed response. I missed your initial post. I have not heard about this problem. Let me check with my team and will get back to you. If you have time can you try unistalling and reinstalling help from ull MSDN Library from the Microsoft Download Center to see if this helps.

     

    I am checking this and thanks for your patience.

     

    Anand..

     

     

    Wednesday, November 28, 2007 6:49 AM
    Moderator
  • Thanks for the response.

     

    I tried repairing the installation and removing and reinstalling the installation.  Neither helped.   I installed it from the disk I created from the MSDN subscription site.

     

    I seem to remember having this same problem with Visual Studio 2005 but I don't remember how it was fixed.

     

    I'll try your suggestion of downloading from the link you provide, uninstalling MSDN Library for Visual Studio 2008 and installing the downloaded version.

     

    I'll let you know if it helps. 

     

    Wednesday, November 28, 2007 12:32 PM
  • I uninstalled MSDN Library for Visual Studio 2008 and installed the downloaded version from the link you supplied.

     

    No luck.  Still no Table of contents or index showing in either the document viewer or Visual Studio 2008.

     

    The text displayed were the table of contents and index usually are:

     

    No index has been defined for the current Help colleciton.

    No table of contents has been defined for the current Help collection.

     

    Please help 

    Thursday, November 29, 2007 3:05 AM
  • Sorry about this Dan,

    Looks like your help system installtion is corrupted. Tey wiping your temp folders. I have also escalated this issue to the MSDN team responsible for this area. They will get back to you soon.

     

    Anand..

     

    Thursday, November 29, 2007 8:09 PM
    Moderator
  • Hi Dan,

     

    It looks like Help merge is broken on your machine.

    If you have any other documentation for example WinSDK etc you might have to re-install after running these steps

     

    1. Rename your Help folder at C:\Program Files\Common Files\Microsoft Shared\Help

    2. Rename your Help 9 folder at C:\Program Files\Common Files\Microsoft Shared\Help 9

    3. Rename nslist.hxl file at C:\Documents and Settings\All Users\Application Data\Microsoft Help

    3. Go to Add\Remove program and run repair on Microsoft Document Explorer 2008

     

    I hope this will fix your broken help experience.

     

    Thanks 

     

    Friday, November 30, 2007 12:36 AM
    Moderator
  • I followed your instructions with some exceptions.

     

    Steps 1 and 2 there were no issues.

    Step 3 was not at the location you specify.  I have Windows Vista so the file is located at C:\ProgramData\Microsoft Help.  I renamed the file here.

    Step 4 was in Control Panel | Programs and Features but when I tried to repair Microsoft Document Explorer 2008 I got a message saying that the program was not installed on the machine and did I want to remove it from the list.

     

    So I tried doing a repair from the installation disk but that just seemed to go though all the steps and do the merging again.  The end result is it did not fix the problem.

     

    I should also say that in addition to the Help and Help 9 directories I have a Help 8 directory.  I have VS 2005 with documentation installed.  I did not rename Help 8.  After doing this the help in VS 2005 is broken.  There are no table of contents or index.

     

    How do I get the help back for VS 2005?  How do I do a repair on Microsoft Document Explorer 2008 if after I rename the directories and files it does not recognize that the program is installed?

     

    Friday, November 30, 2007 12:00 PM
  •  

    Hi Dan, sorry you are experiencing issues with MSDN.

    Let me take this over from Khairun and work with you to resolve this issue.

    Please undo Steps 2 and 3 above. This should enable you to repair Document Explorer 2008.

     

    After you run a repair, please check:

    • Is your initial problem still repros?
    • Please launch MSDN for VS 2005 though Start->All Programs->Microsoft Developer Network->MSDN for VS 2005. Does it show help?
    • If you have any other documentation installed, please check if it is working or not

     

    Also, could you please send me nslist.hxl to my e-mail: mariash@microsoft.com. I would like to see if the file is corrupted or not.

     

    Thank you in advance

    Maria Shneerson, MSDN Dev Lead

    Friday, November 30, 2007 8:45 PM
  • After completing the steps above there is some improvement.  The repair did work this time.  Here is what I get:

     

    I have an index and a table of contents from within Visual Studio .Net 2005 again.  F1 help is also working and locating local help files.

     

    Everything else displays:

     

    No Table of Contents has been defined.... when the Contents is opened from document explorer or within Visual Studio 2008

    No Index has been defined.... when the Index is opened from document explorer or within Visual Studio 2008

     

    I can search from any of the applications and find local and online content but there is no table of contents or index.  F1 help also fails if I don't have online options enabled in Visual Studio 2008.

     

    I have sent you the file you requested.

    Friday, November 30, 2007 11:41 PM
  • Document Explorer team is further investigating this issue. So far, we've found a workaround for Dan - to use the libraries as an admin (This is a workaround for Vista only).

    Thanks

    Maria

     

    Monday, December 10, 2007 10:56 PM
  • Exactly the same hapens to me. I have uninstalled and reinstalled several times, tried to remove all the trace of the previous installation but nothing helps. I cannot make the MSDN for MSVS2008 work.
    Tuesday, March 24, 2009 9:27 PM
  • I have just installed VS2008 and SQL Express 2008.  I get no index for SQL and only get a response to a search from the online sources.  Local responses are only returned when I restrict the scope of the search to local only.

    VS 2008 help however is restricted to SQL2008 help only

    VS 2005 and SQL2005 are also installed.  Help on these works normally
    Wednesday, April 15, 2009 12:58 PM
  • Doesn't work for me.  I just installed EntLib 4.1.  Previously all good, now - toasted.

    Have tried repair - no luck.  This is pretty flaky.

    Ideas anybody?
    Wednesday, May 06, 2009 6:00 AM
  • I had the same issue after installing the Enterprise Library. I fixed it as follows:

    1. Repair Microsoft Document Explorer 2008 in Add/Remove Programs
    2. Run Microsoft Visual Studio 2008 Documentation - this caused the help index to be recreated and now everything is working again.

    The solution proposed by Khairun Jamal didn't work as renaming these folders led Add/Remove Programs to believe that Microsoft Document Explorer 2008 wasn't even installed which could get you into a much worse mess when it comes to trying to remove it for real.
    • Proposed as answer by Bill MacAdam Saturday, January 16, 2010 12:22 AM
    Friday, June 05, 2009 1:48 PM
  • Unfortunately this solution did not help me. I downoladed and installed MSDN Library for Visual Studio 2008 from Microsoft download center. I am using Windows 7 Starter Edition.
    Tuesday, November 22, 2011 11:45 AM
  • I think I have a solution :

    - Go to the folder Documents and Settings\All Users\Application Data

    - Go to the security and enlarge the access rights (total control) for you and more if possible

    - And maybe, unmark read-only access right

    - Open the VS help

    It seems that some applications change the security settings when installing...


    • Edited by Louis10 Monday, December 10, 2012 3:16 PM
    Monday, December 10, 2012 3:09 PM