locked
MDS Group Email Notifications not working RRS feed

  • Question

  • I currently have an issue with MDS Notifications

    In regards to email notifications I cannot get the group account (Set up in Active Directory) to send out emails.
    However when I change the Notification to my user for the business rule, I do then get the emails.

    I have checked things such as Group permissions, DBMail and Service Broker, all seems to be set and working correctly.

    Are there any known issues with using groups for notifications in MDS that you know of ?

     

    Monday, August 23, 2010 6:22 AM

Answers

  • Hi Guys,

    First of all, thanks everyone for their feedback.

    After double and triple checking all settings it came down to a couple of things that got Group Emails working:

    1. Made sure the group user had db_owner privileges.

    2. We changed the Active Directory Group Type from distribution to security

     

     

    Now group email notifications are working.

     

     

    • Marked as answer by GM33 Tuesday, August 31, 2010 1:40 AM
    Sunday, August 29, 2010 10:03 PM

All replies

  • Are you using the latest CU2 version?

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2072493&kbln=en-us

    There may have been an issue fixed for group notifications.

    Monday, August 23, 2010 8:44 PM
  • We had installed hotfix SQLServer2008R2_RTM_CU2_2072493_10_50_1720_x86

    So I believe yes we have latest CU2 version installed.

     

    Tuesday, August 24, 2010 2:05 AM
  • Hello

    did you check the sql server log / run a trace ?


    Xavier Averbouch
    Tuesday, August 24, 2010 7:23 AM
  • Hi,

    Yes checked Sql Server Log and also turned on LogFileListener in web.config file. There were no error messages in either logs.

    One thing I have noted that may or may not be relevant is, when I look at Manage Users I can see in the General tab an email address for user. When I look at Manage Groups I do not see email for the group.

    Wednesday, August 25, 2010 11:38 PM
  • Is your user a member of the group?  If not, have the group members logged into MDS at least once?

     

    Thursday, August 26, 2010 1:34 PM
  • Yes my user is a member of the group. My user has logged into MDS.

    Not all users of the group have logged into MDS, is that an issue?

    I will log in each member of the group and see what happens.

     

    Friday, August 27, 2010 4:05 AM
  • Denise has right, GM33, MDS has this rule for groups that you have to log on at least once to MDS in order to have a notification. This in order to avoid mass mailings.
    Marius
    Friday, August 27, 2010 8:05 AM
  • Hi Guys,

    First of all, thanks everyone for their feedback.

    After double and triple checking all settings it came down to a couple of things that got Group Emails working:

    1. Made sure the group user had db_owner privileges.

    2. We changed the Active Directory Group Type from distribution to security

     

     

    Now group email notifications are working.

     

     

    • Marked as answer by GM33 Tuesday, August 31, 2010 1:40 AM
    Sunday, August 29, 2010 10:03 PM