locked
Sqlite incompatibility or missing configuration? RRS feed

  • Question

  • User346480 posted

    This app works just fine on android, but when I try to use Xamarin Live Player, it gives me this message :

    Start (Mobile.Android, LGE LG-H422 Player, ). Attempting connection to debug address: 10.2.1.78:37847. Connected to: 10.2.1.78:37847. Deploying C:\Projetos\ECS_APP\Mobile\Mobile.Android\Mobile.Android.csproj... Got device info: LGE LG-H422 Player (Android) @ 10.2.1.78:37847 Synchronizing files... Building and running... Built with 2 messages. (1,1): error: Failed to load assembly from stream: System.AggregateException: One or more errors occurred. ---> System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/data/com.xamarin.live/files/.nuget/packages/sqlitepclraw.lib.e_sqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.lib.e_sqlite3.dll". at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share, System.Int32 bufferSize, System.Boolean anonymous, System.IO.FileOptions options) [0x0017d] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at System.IO.FileStream..ctor (System.String path, System.IO.FileMode mode, System.IO.FileAccess access, System.IO.FileShare share) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare) at System.IO.File.OpenRead (System.String path) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at .$LocalFileSystem+Upsight-IFileSystem-OpenReadAsync@49-1.Invoke () [0x00012] in <5a25f3b111b47c3aa7450383b1f3255a>:0 at System.Threading.Tasks.Task`1[TResult].InnerInvoke () [0x0000f] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at System.Threading.Tasks.Task.Execute () [0x00010] in <896ad1d315ca4ba7b117efb8dacaedcf>:0

    am I missing some configuration or its just incompatibility with SQLite .net?

    Tuesday, December 12, 2017 5:56 PM

All replies

  • User299422 posted

    Me too I am also facing the same issue. Its like when you add SQLite PCL nuget and try running on Xamarin Live player, you start getting this error. And funny thing is that, even if I comment out the code related to SQLite I am still getting this error. I am creating blank Xamarin forms PCL project and adding SQLite PCL nuget. Can anybody let us know what is going on. Please.

    My code snippet After adding SQLite PCL nuget, I added the following code to get the folderpath. Thats it. `string dbName = "myTest_db.sqlite";

    string folderPath = Path.Combine(System.Environment.GetFolderPath(System.Environment.SpecialFolder.Personal), "..","Library" );

    string fullPath = Path.Combine(folderPath, dbName);

    LoadApplication(new App(fullPath));`

    Getting following error

    (Inner Exception #0) System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/var/mobile/Containers/Data/Application/6F5CE45D-A870-4B49-8C29-82667C6F79D0/Documents/.nuget/packages/sqlitepclraw.provider.sqlite3.ios_unified/1.1.5/lib/Xamarin.iOS10/SQLitePCLRaw.provider.sqlite3.dll".

    Sunday, December 17, 2017 12:41 PM
  • User362176 posted

    I get similar error when I add the the sqlite-net-pcl package from Nuget, set up a IFileHelper interface and Dependency Service for the 3 platforms (Android, IOS and UWP). I can run Windows Emolator, but when I run Android phone over Live Player, I get 2 errors: "Error Failed to load assembly from stream: System.AggregateException: One or more errors occurred. ---> System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/user/0/com.xamarin.live/files/.nuget/packages/sqlitepclraw.provider.esqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.provider.esqlite3.dll". at System.IO.FileStream..ctor.........." AND "System.IO.FileAccess access, System.IO.FileShare share) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare) at System.IO.File.OpenRead (System.String path) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at .$LocalFileSystem+Upsight-IFileSystem-OpenReadAsync@49-1.Invoke () [0x00012] in <5a566e3f11b47c3aa74503833f6e565a>:0 at System.Threading.Tasks.Task`1[TResult].InnerInvoke () [0x0000f] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at System.Threading.Tasks.Task.Execute () [0x00010] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 --- End of inner exception stack trace --- --- End of inner exception stack trace --- ---> (Inner Exception #0) System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/user/0/com.xamarin.live/files/.nuget/packages/sqlitepclraw.lib.esqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.lib.esqlite3.dll". at System.IO.FileStream..ctor

    Friday, January 19, 2018 2:30 PM
  • User362176 posted

    I get similar error when I add the the sqlite-net-pcl package from Nuget, set up a IFileHelper interface and Dependency Service for the 3 platforms (Android, IOS and UWP). I can run Windows Emolator, but when I run Android phone over Live Player, I get 2 errors: "Error Failed to load assembly from stream: System.AggregateException: One or more errors occurred. ---> System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/user/0/com.xamarin.live/files/.nuget/packages/sqlitepclraw.provider.esqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.provider.esqlite3.dll". at System.IO.FileStream..ctor.........." AND "System.IO.FileAccess access, System.IO.FileShare share) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare) at System.IO.File.OpenRead (System.String path) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at .$LocalFileSystem+Upsight-IFileSystem-OpenReadAsync@49-1.Invoke () [0x00012] in <5a566e3f11b47c3aa74503833f6e565a>:0 at System.Threading.Tasks.Task`1[TResult].InnerInvoke () [0x0000f] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at System.Threading.Tasks.Task.Execute () [0x00010] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 --- End of inner exception stack trace --- --- End of inner exception stack trace --- ---> (Inner Exception #0) System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/user/0/com.xamarin.live/files/.nuget/packages/sqlitepclraw.lib.esqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.lib.esqlite3.dll". at System.IO.FileStream..ctor

    Friday, January 19, 2018 2:30 PM
  • User362176 posted

    I get similar error when I add the the sqlite-net-pcl package from Nuget, set up a IFileHelper interface and Dependency Service for the 3 platforms (Android, IOS and UWP). I can run Windows Emolator, but when I run Android phone over Live Player, I get 2 errors: "Error Failed to load assembly from stream: System.AggregateException: One or more errors occurred. ---> System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/user/0/com.xamarin.live/files/.nuget/packages/sqlitepclraw.provider.esqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.provider.esqlite3.dll". at System.IO.FileStream..ctor.........." AND "System.IO.FileAccess access, System.IO.FileShare share) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare) at System.IO.File.OpenRead (System.String path) [0x00000] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at .$LocalFileSystem+Upsight-IFileSystem-OpenReadAsync@49-1.Invoke () [0x00012] in <5a566e3f11b47c3aa74503833f6e565a>:0 at System.Threading.Tasks.Task`1[TResult].InnerInvoke () [0x0000f] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 at System.Threading.Tasks.Task.Execute () [0x00010] in <896ad1d315ca4ba7b117efb8dacaedcf>:0 --- End of inner exception stack trace --- --- End of inner exception stack trace --- ---> (Inner Exception #0) System.AggregateException: One or more errors occurred. ---> System.IO.DirectoryNotFoundException: Could not find a part of the path "/data/user/0/com.xamarin.live/files/.nuget/packages/sqlitepclraw.lib.esqlite3.android/1.1.5/lib/MonoAndroid/SQLitePCLRaw.lib.esqlite3.dll". at System.IO.FileStream..ctor

    Friday, January 19, 2018 2:32 PM
  • User25759 posted

    We have this on our list and working on a fix.

    Saturday, January 20, 2018 1:42 AM
  • User365751 posted

    Is there any update on this.. The issue is still there as of today. Any solution /workaround..

    Thanks

    Friday, February 23, 2018 4:09 AM
  • User364269 posted

    @mtsarwar said: Is there any update on this.. The issue is still there as of today. Any solution /workaround..

    Thanks

    Good question. @JamesMontemagno, Did you have some news about? Or a link to us keep updated? Workaround for me was use LiveXaml, that was a life changing at my work., for my mission critical app. But I really want to use live player. However, I can't risk get stuck on this kind of problem. :neutral:

    Monday, March 12, 2018 7:17 PM
  • User366510 posted

    Has there been any feedback presented yet regarding this issue? I am also experiencing the same problem with XLP and my IOS device. I see a lot of mention on various threads and sites, but no presented solutions as of yet.

    Wednesday, March 21, 2018 1:46 PM
  • User364269 posted

    There's no solution to this yet. We need to keep waiting for this. :neutral:

    Wednesday, March 21, 2018 1:49 PM
  • User366605 posted

    We have this on our list and working on a fix.

    I don't see anything in the github projects or issues about this. Is it actually being worked on?

    Saturday, March 24, 2018 4:22 AM
  • User366754 posted

    @adamdusty said:

    We have this on our list and working on a fix.

    I don't see anything in the GitHub projects or issues about this. Is it actually being worked on?

    Experience so far tells me that these forums are useless. Issues are not always seen, and until you open something in Bugzilla nobody works on it. Another user told me to find another platform, I thought he was joking, now I am not so sure. Xamarin might not be production ready. If you get it working, never ever update anything.

    Monday, April 2, 2018 3:37 PM
  • User74 posted

    @ernestochaveschaves you know Live Player is only in pre-release/beta, right? I agree that Live Player isn't production ready, but don't tar all of Xamarin with your experience using Live Player.

    Tuesday, April 3, 2018 9:51 AM
  • User366754 posted

    I am using all of my experience getting weird build and debugging errors with Xamarin, although it is limited to a few weeks, I have done this for a while, some platforms are more stable than others, and I can tell Xamarin isn't as stable. It is fair that LP is a preview. I stand by the fact that this forum will never get any attention on platform issues. I think you need to report it somewhere else so it is looked at. Anyway, I would wait until the player gets out of beta then.

    Thanks,

    Tuesday, April 3, 2018 3:17 PM
  • User367072 posted

    @JohnHair said: @ernestochaveschaves you know Live Player is only in pre-release/beta, right? I agree that Live Player isn't production ready, but don't tar all of Xamarin with your experience using Live Player.

    I didn't know. Maybe it should say that at some point in the process. Should just work out of the box.

    Just installed visual studio, file new project, F5. Live player dialog. Install Live player Pair F5 Failure

    Sunday, April 8, 2018 3:04 AM
  • User367065 posted

    any soloutions right now?

    Sunday, April 8, 2018 11:53 AM
  • User74 posted

    @NN97 said: any soloutions right now?

    I would continue using real devices to develop on, a better experience than using emulators, simulators, and much better than Live Player.

    Sunday, April 8, 2018 5:24 PM
  • User367539 posted

    Any Solution on this?. I have the same issue...

    Thursday, April 19, 2018 5:38 AM
  • User54695 posted

    Are you sure Live Player is still beta? The preview warning has been removed from this page: https://docs.microsoft.com/en-us/xamarin/tools/live-player/

    Ever since release of Live Player, I've not been able to use it.. Because who makes an app without any kind of database?

    Sunday, May 20, 2018 11:25 AM
  • User74 posted

    @Inrego said: Are you sure Live Player is still beta? The preview warning has been removed from this page: https://docs.microsoft.com/en-us/xamarin/tools/live-player/

    Ever since release of Live Player, I've not been able to use it.. Because who makes an app without any kind of database?

    Interesting, if that's the case they should move the forum out of the Prerelease & Betas section.

    I would be surprised if it is out of beta, in my opinion it is not production ready except for the most simple of apps.

    Monday, May 21, 2018 9:31 AM
  • User383752 posted

    Hi,

    I have added system.buffer nuget for whole solution after that i can run it in emulator. I am making this for sample project masterdetail page.

    Friday, March 22, 2019 10:05 AM