none
Report preview displays a 0 for a drop-down field box on a Form where nothing is selected RRS feed

  • Question

  • So I just inherited a task to fix an issue that happened after an Access Database got upgraded to 2016 from 2013.  When the user goes to preview a report from a form, the report is displaying a '0' for a field where nothing is selected from the drop-down on the Form.  Here are the parameters of the Combo box from the Form.

    Control Source -  TestBy

    Row Source: SELECT tblLKPInitials.InitID, tblLKPInitials.Initials FROM tblLKPInitials;

    Row Source Type: Table/Query

    Bound Column: 1

    Limit to List: Yes

    Inherit Value List: No

    Show only Row Source Value: No

    Input Mask:

    Enabled: Yes

    I'm a newbie to MS Access Reports/Forms are concerned, so any help would be appreciated. 

    Thanks!


    • Edited by eharvilicz Thursday, March 14, 2019 1:55 PM
    Thursday, March 14, 2019 1:42 PM

All replies

  • Is the Default Value property of the combo box set to 0?

    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Thursday, March 14, 2019 3:45 PM
  • Nope, I checked that already..it's blank.  What's crazy is if I select something from the drop-down, and set it back to blank it doesn't pull up the 0 in the report.
    Thursday, March 14, 2019 4:14 PM
  • Could you create a copy of the database, strip away everything that isn't relevant to the problem, as well as all sensitive information, then zip this copy and make it available through one of the websites that let you upload and share a file, such as OneDrive, Google Drive, FileDropper or DropBox. Post a link to the uploaded and shared file in a reply here.

    Or register at www.eileenslounge.com (it's free) and start a thread in the Access forum. You can attach files up to 250 KB to a post there.


    Regards, Hans Vogelaar (http://www.eileenslounge.com)

    Thursday, March 14, 2019 8:13 PM