locked
Currituck 'Access denied' error from web service. RRS feed

  • Question

  • Developing a web service to expose the WorkItem store (Currituck). It works OK running in the development server from the IDE, but deployed to the IIS server attempting to access any of its methods returns:

    System.ApplicationException: another fine error! --->
     System.UnauthorizedAccessException: Access is denied. (Exception
     from HRESULT: 0x80070005 (E_ACCESSDENIED)) at
     Microsoft.VisualStudio.Currituck.DataStore.
     HandleComException(Exception e, Int32 hr)

    at Microsoft.VisualStudio.Currituck.DataStore.DatastoreClass.ConnectEx(
     String connectionString, Int32 hCredentials)

    at Microsoft.VisualStudio.Currituck.Client.WorkItemStore.Initialize()

    at Microsoft.VisualStudio.Currituck.Client.WorkItemStore..ctor(
     TeamFoundationServer teamFoundationServer)

    at Microsoft.VisualStudio.TeamFoundation.Client.
     TeamFoundationServer.GetService(Type serviceType)

    at OurNamespace.HelperClass.Worker.Connect(String tfsServer,
     String connectionString) in ...HelperClass\Worker.cs:line 48

    --- End of inner exception stack trace ---

    at OurNamespace.HelperClass.Worker.Connect(String tfsServer,
     String connectionString) in ...Helper2\HelperClass
     \Worker.cs:line 55

    at OurNamespace.HelperClass..Common.IDRWorker..ctor(String tfsServer, String
     dbConnectionString) in ...Common2\DRCommon2\idrworker.cs:line 14

    at OurNamespace.HelperClass.HelperClass.Worker..ctor(String tfsServer,
     String connectionString) in ...HelperClass\Worker.cs:line 23

    at Service..ctor()

    Currently the web service is configured to use the TFSService account, which has absolute permission for just about anything in the system, including the Currituck data store, and certainly has more permissions than the user who accesses the data when testing the service in the development server. I'm at a bit of a loss. Can anyone offer any suggestions?

    daniel

    Wednesday, May 4, 2005 4:33 PM

Answers

  • I added TFSService to the local machine Administrator group, and now it works.
    Wednesday, May 4, 2005 9:14 PM

All replies

  • You are using Currituck Object Model to develop a web service and you are getting an error on connect, correct?

    You mentioned that the IIS app pool hosting the service you are developing is running under TFSService account that has all rights to the machine and to the datastore.

    But, to what groups does TFSService account belongs to in Team Foundation. Can you try logging on to the IDE as TFSService account and see if you can connect successfully. If this is successful then you can eliminate the Team Foundation permissions as the reason for this.

    Also, remember that as a part of connect, the Object Model creates caches on the local machine. When you are running on the IIS server make sure, the app pool account has permissions for this.

    Let me know what you find and if you still have problems let me know and i can help you run some traces to figure out the root cause.

    -- Venkat

    Wednesday, May 4, 2005 6:09 PM
  • I added TFSService to the local machine Administrator group, and now it works.
    Wednesday, May 4, 2005 9:14 PM