none
Visual Studio 2015 Universal Windows App development: WYSIWYG problem, unable to see dropped controls from the toolbox

    Question

  • Hi,

    I'm new to Universal Windows App development. I have a problem using Visual Studio 2015 Universal Windows App development. I can't see my dropped controls from the toolbox. For example, when I drop a Button control (named "Mybutton") from the toolbox on MainPage.xaml, the XAML code will change as expected:

    <Button x:Name="Mybutton" Content="Button" Height="100" Width="100"/>

    Although the XAML code has been changed, I can't see my button control as illustrated in the image below.

    A classic WPF solution in VS2015 on the other hand is showing my button as expected:

    What am I doing wrong?

    Thursday, December 29, 2016 12:10 PM

All replies

  • Hi!

    You did nothing wrong.

    Your XAML code is good.

    Therefore the XAML designer has some problems sometimes. So have you tried to :

    • Build your project
    • Close your windows designer and reopen it. Normally It should work.

    Hope it wil be useful.

    If it's good for you, can you mark this answer as answer of your question please?

    Follow me on twitter : https://twitter.com/NordineMhoumadi


    Please remember to close your threads by marking helpful posts as answer and then start a new thread if you have a new question. Please don&amp;amp;amp;amp;#39;t ask several questions in the same thread. SVP utiliser le Marquer comme reponse; sur les reponses qui vous aide car cela permet aux personnes qui peuvent rencontrer le meme probleme que vous, de retrouver rapidement quelle est la reponse qui a resolu leur probleme. De plus, cela encourage aussi la personne qui a repondu a votre question, et de repondre aux suivantes...

    Thursday, December 29, 2016 12:32 PM
  • Maybe you simply should scroll the Designer using the vertical scrollbar or mouse wheel.

    Thursday, December 29, 2016 5:35 PM
  • Hi @MobileBoy36 ,@Nordine and Viorel,

    Thank you for posting in MSDN forum.

    Thanks Nordine and Viorel for sharing your solution and opinion.

    I agree with both of them:

    Firstly, please run your App to check if the button does really show as normal.

    Then click the icon as below, set the High Contrast : Default

    Also, as Viorel said, scroll up and download to check the button to show the bottom, and you'd better set Zoom around 100%, as we could see in your screenshot, the Zoom is about 19%

    Best Regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 30, 2016 7:13 AM
    Moderator
  • Hi all,

     

    I tried all the suggestions described in the posts above.

    Unfortunately,  none of them solved the problem.

     

    Some additional info:

     

    • Rebuilding the project does not work
    • Closing and reopening windows designer did not work
    • Scrolling down and up does not Visualize the button
    • A classic XAML project does show a white container to drop your controls. The UPW type VS project doesn’t
    • Zoom is at 100%
    • Changing the color scheme doesn’t help
    • When running the application, I can see the button. The designer on the other hand is not showing the button
    • When opening the project on another PC from my colleague we have the following situation:
      • A white container to drop your controls is displayed (on my pc it isn’t) in the designer
      • It possible to drop controls on my colleague’s pc

     

    • My PC is running Windows 10 (I installed Windows 10 from scratch)
    • My colleagues PC is running Windows 10 (he installed Windows 10 update from Windows 8.1)

    I'm willing to share this problem with Microsoft. You can remote control my PC or I can Zip the project and post it.

    Thanks.

     




    Monday, February 13, 2017 3:55 PM