locked
Windows 7 64bit HP Hibernate

    Question

  • Hi, I have Windows 7 64bit Home Premium preinstall on a HP Computer.

     

    I have been using the Hibernate for some time. Then one day, I put Windows in Hibernate, several hours later (about 5) the computer was still 'on' (normally the computer would power off after about 5 min) but the monitor was not displaying anything (in standby), so I pressed the power button to turn the computer off (hard off).

     

    When I started the computer the following day, I received a message that the computer did not power off correctly and asked how I wanted to start the computer. I chose 'Normal' and everything worked fine, however when I later tried to put the computer in hibernation the monitor turns off for about 3 seconds, then turns back on. The computer does NOT go into hibernation.

     

    I went through different tests, and even disabled and re-enabled Hibernation through the command line options (powercfg). The computer does not go into hibernation anymore. No software or hardware changes were made, simply Windows its self would did not complete going into hibernation so I powered off the computer.

     

    The computer does power off, restart and even goes into sleep mode just fine, it will not, however go into hibernation anymore.

     

    The command line option to get the status of the hardware that wakes the computer reports this after trying to have the computer hibernate:

    C:\Windows\system32>powercfg  -LASTWAKE
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 0

    C:\Windows\system32>

     

    There are no devices set that can wake the computer, not even wake on lan:

    C:\Windows\system32>powercfg  -devicequery wake_armed


    C:\Windows\system32>

     

    As this is directly related to a hibernation 'crash' followed by me powering off the computer, the issue can only be some corruption within the system its self.

     

    What other methods can be followed to resolve this? I would prefer NOT reinstalling the system as the reinstallation is a recovery and not a real installation and simply to time consuming for a bug in the hibernation module in Windows. From what I see allot of people are reporting this on the net, is there perhaps a fix available, even as a tester?

    Saturday, December 3, 2011 12:44 PM

Answers