none
Remote Performance Monitor problem RRS feed

  • Question

  • I have just created an new CE6 R3 Image for an ARM board.  Both the DEBUG and the RELEASE compilation of the image are working.

    The Remote Performance Monitor can run on the DEBUG build but not on the RELEASE build.

    When I press the "Add" button to add a new graph to the monitor, the "Add to Chart" window is displayed with empty fields.  And the RELEASE image seems to crash.

    All the other Remote Tools are working correctly. Does anyone have an idea what can be causing this?

    I have tried to make the connection from an other PC containing a Platform Builder with exactly same results.

    Thursday, March 1, 2012 2:29 PM

All replies

  • Check the Build Options in your OS Design properties. These may have changed in the switch between Debug and Release.

    You must have "Enable kernel debugger" option checked to use the Performance Monitor.

    See here:

    How to Use Performance Monitor to Observe Performance

    Monday, March 5, 2012 5:15 PM
  • Thank you for your answer.  But I do not think it is correct that I need to "Enable kernel debugger" to run the remote tools.  I already have a x86 image were it is not enabled and I am able to use all the remote tools, inclusive the Performance Monitor.  And as I mentioned above all the remote tools are working on the ARM board except for the Performance Monitor.  But anyhow, I tried your suggestion but it did not help my problem.
    Tuesday, March 6, 2012 9:46 AM
  • Have you completely disabled your firewall? I guess you should not even have gone to this point with an enabled firewall, but maybe it blocks only some frames.

    Otherwise, I am afraid that you should try with a clean install of Platform Builder on another machine (a Virtual PC one should be sufficient)...

    Thursday, March 8, 2012 5:06 PM