locked
Windows Mobile Device Center (WMDC) on Windows 2008 RRS feed

  • Question

  • We are using:
    - Windows 2008 with Desktop Experience feature installed
    - DMA is enabled on WMDC
    - Visual studio 2005 (SP1)
    - Device Emulator 2.0
    - Office 2007 is not currently installed

     

    When we attempt to connect any emulator (using "Cradle") to the WMDC the emulator looks as if it is connected but nothing appears in WMDC. We have tried re-installing WMDC and the device emulator.

     

    Does anyone have any other ideas of what we can try?

     

    Thanks,

    C

    Tuesday, July 29, 2008 12:04 PM

Answers

All replies

  • Windows 2008 is 64-bit only.  Unfortunately, the DeiceEmulator 2.0 DMA plugin DLL to ActiveSync/WMDC is 32-bit and fails to load in the 64-bit WMDC process.

     

    Device Emulator 3.0 has two downloads, one for 32-bit and one for 64-bit, at http://www.microsoft.com/downloads/details.aspx?familyid=A6F6ADAF-12E3-4B2F-A394-356E2C2FB114&displaylang=en.  The 64-bit version should work for you, and is backward-compatible with VS2005 SP1 and your existing Windows Mobile OS images.

     

    Barry

     

     

    Wednesday, July 30, 2008 4:13 AM
  • We are running a 32-bit version of Windows 2008 Standard. We can see "32 bit Operating System" in the "System Type" field in the "System" details in "Control Panel". Most editions of Windows Server 2008 are available in x86-64 (64-bit) and x86 (32-bit) versions, see the following link: http://en.wikipedia.org/wiki/Windows_Server_2008#Editions

    We have tried the "Device Emulator 3.0" but still cannot get the emulator to display in WMDC.

    Wednesday, July 30, 2008 7:44 AM
  • Once an image is cradled, doesn't show up in the WMDC. I have Visual Studio 2008 Team System. I'm trying to cradle a WM5 Pocket PC emulator. My OS is Windows Server 2008 Enterprise. I have enabled the Desktop feature and installed the WMDC 6.1 after the Desktop feature was configured.

     

    My ultimate goal is to have a Internet connection on the emulator device since my application accesses the Web. Any ideas how to make that happen?

     

    - George Jordanov Ivanov

    Thursday, November 13, 2008 12:31 AM
  • Can you open WMDC, and click on "Mobile Device Settings", and see what shows up there?  The DeviceEmulator will sync only if "Allow connections to one of the following:" is checked, and "DMA" is selected from the dropdown combobox. 


    Barry

     

    Thursday, November 13, 2008 1:07 PM
  • Thanks Barry! Bluetooth connection is chosen on default. After changing it to DMA, now the cradled images from VS2008 show up in WMDC. Even more, I managed to configure the Internet connection on them too.

     

    - George

    Thursday, November 13, 2008 3:53 PM