none
Code Window Does Not Show Full Scrollbars (Just Up/Down Arrows)

    Question

  • The code window and others, like the Immediate Window, only show up and down arrows instead of the entire navigation scrollbar.  The Solution Explorer does show the entire scrollbar.  I tried resetting All Settings from the Import and Export Settings Wizard but it did not fix the problem.  Something happened to change my settings a few days ago but I don't know what.  How do I fix this?


    -chris



    Friday, October 21, 2016 3:14 PM

Answers

  • I am using Visual Studio Ultimate 2012 Version 11.0.50727.1 RTMREL

    I opened a new type of project and still have the small scrollbar problem.  I tried closing all windows and reopening but no luck.  

    I then looked for update and saw that one was available.  After applying the update the IDE is working properly with the full scrollbars now showing.

    Thanks for your help.


    -chris

    • Marked as answer by Chris Heltzel Tuesday, October 25, 2016 10:38 AM
    Tuesday, October 25, 2016 10:37 AM

All replies

  • Hi Chris,

    I got the result like the following screen shot using the default settings of the VS2015:

    But if I min the immediate window, I could get the following result. So you could change the window size, check it again.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, October 24, 2016 12:30 PM
    Moderator
  • I minimized the Immediate window as well as set it to floating, but the scroll bars never changed to full size.  I also tried floating and re-docking the code window, but that did not work either. 

    Thanks for looking into this, Jack, but the problem persists on my computer.


    -chris

    Monday, October 24, 2016 12:56 PM
  • Hi Chris,

    What's your VS version?

    I tried to open a new VB project in my VS 2012, and I found the scroll bar display normally as below, please try to create a new project with other project type and see if the same issue will happen or not?

    Please try to close the editor windows and Immediate Windows, then add them back through double click the vb file under Solution Explorer and DEBUG-Windows-Immediate.

    Meanwhile, you can try to open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE and run the command: devenv /safemode: Launches the IDE in safe mode loading minimal windows and check if the issue again. If the scroll bar works fine using the safe mode, that means the installed extensions that caused this issue, please go to Tools—Extensions and Update… and remove the installed extensions one by one to find the culprit.

    If you used the VS 2013 or 2015, please right click the Scroll bar that have issue and choose 'Scroll Bar Option...' or directly click the Tools-Options-Text Editor-All Languages-Scroll Bars, then recheck the option 'Show horizontal scroll bar' and 'Show vertical scroll bar' like the following screenshot:

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, October 25, 2016 8:14 AM
    Moderator
  • I am using Visual Studio Ultimate 2012 Version 11.0.50727.1 RTMREL

    I opened a new type of project and still have the small scrollbar problem.  I tried closing all windows and reopening but no luck.  

    I then looked for update and saw that one was available.  After applying the update the IDE is working properly with the full scrollbars now showing.

    Thanks for your help.


    -chris

    • Marked as answer by Chris Heltzel Tuesday, October 25, 2016 10:38 AM
    Tuesday, October 25, 2016 10:37 AM
  • Hi Chris,

    I'm so glad to hear that your issue is solved and thank you for your sharing, it will help other community members who have the same or similar issue to search this solution.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, October 26, 2016 1:19 AM
    Moderator