none
Project Server 2010 -- Cannot Add Enterprise Custom Fields to WebPart RRS feed

  • Question

  • I am working to configure our Project Server 2010 implementation.   I have created custom enterprise fields and have set their behavior attributes to "Work-flow Controlled".  When I attempt to build a PDP and add those fields via the Project Web App --> Project Fields WebPart, I receive the following error:  "Project fields have not been defined for display in this webpart or departmental filtering has excluded all fields from being displayed. For more information contact your administrator."  I have not configured departmental filtering.   Any insight into what is missing or mis-configured will be appreciated.  -- Jim
    Tuesday, July 19, 2011 3:05 PM

Answers

  • I solved my issue.  It boils down to a misunderstanding of how the process works:  Adding the web part, and then using the field picker to add the fields.   Because I received the error message immediately upon adding the web part, and before using the field picker, I thought there was something wrong -- when in fact there was nothing wrong.   Thanks for your patience and help Brian.
    JB Fink
    • Marked as answer by JB Fink Wednesday, July 20, 2011 9:08 PM
    Wednesday, July 20, 2011 9:08 PM

All replies

  • Is it possible that you picked the Project Fields (Backwards Compatable) webpart instead of just "Project Fields"?


    Brian Kennemer – DeltaBahn Senior Architect
    Blog | Twitter | LinkedIn
    Tuesday, July 19, 2011 4:08 PM
    Moderator
  • Brian,

    No, I have verified that I used "Project Fields" instead of the Backward Compatible webpart.


    JB Fink
    Tuesday, July 19, 2011 5:53 PM
  • OK. I had to check.

    And you said you dont have any departments setup correct? These fields do not have a department value on them?

     

    Also, what if you remove the "Workflow Controled" setting for the fields? Does it let you add them then?


    Brian Kennemer – DeltaBahn Senior Architect
    Blog | Twitter | LinkedIn
    Tuesday, July 19, 2011 6:22 PM
    Moderator
  • That's correct.  No departments and the fields do not have any department designations.   It fails in the same manner, regardless of the Workflow Controlled parm setting.


    JB Fink
    Tuesday, July 19, 2011 7:40 PM
  • Brian,

    The referenced thread certainly seems to be akin to my problem.  Like the gentleman in the thread, I am able to pull fields into the PDP using the Backwards Compatible webpart, but I am not able to pull in fields fields using the Project Fields webpart.  That thread talks about loading one or more default fields first as means for "waking up" (my words) the Project Fields webpart.  I'm not clear on how to load the default fields.... I believe doing so requires using the Project Fields webpart.  Doesn't it?


    JB Fink
    Tuesday, July 19, 2011 8:25 PM
  • OK, before you said you were trying to put fields into the Project fields webpart. Now you say you are trying to put them in the backwards compatable projct fields web part. You cannot put workflow controlled fields into the backwards compatable web part.

     

    you put default fields (Start, Finish, Name, % Complete, etc) into either web part the same way you do for any other field. You insert the field into the web part, edit the web part and then click the Modify button and select fields.


    Brian Kennemer – DeltaBahn Senior Architect
    Blog | Twitter | LinkedIn
    Wednesday, July 20, 2011 2:58 PM
    Moderator
  • Sorry for the confusion; let me clarify.   I am trying to put fields into the Project Fields webpart.  I went through the extra step of trying the backwards compatible webpart simply to see if my problem behaves in the same manner as that which was described in that other posting.  I found that yes it does behave in the same manner.
    JB Fink
    Wednesday, July 20, 2011 3:45 PM
  • What what happens if you follow the suggestion in the thread I sent you?
    Brian Kennemer – DeltaBahn Senior Architect
    Blog | Twitter | LinkedIn
    Wednesday, July 20, 2011 3:47 PM
    Moderator
  • I solved my issue.  It boils down to a misunderstanding of how the process works:  Adding the web part, and then using the field picker to add the fields.   Because I received the error message immediately upon adding the web part, and before using the field picker, I thought there was something wrong -- when in fact there was nothing wrong.   Thanks for your patience and help Brian.
    JB Fink
    • Marked as answer by JB Fink Wednesday, July 20, 2011 9:08 PM
    Wednesday, July 20, 2011 9:08 PM