locked
Failed to map the path '/' when building web site RRS feed

  • Question

  • User-488364715 posted

    Ok, so I'm trying to debug a web application, and I'm receiving the error message Failed to map the path '/'. The strange thing is that Visual Studio doesn't reference where (the file causing the problem) the error is coming from, or any additional information such as line number, column or project (they are all blank). When I look at the output window this is displayed:

     

    ------ Build started: Project: http://localhost/, Configuration: Debug Any CPU ------
    Validating Web Site
    : Build (web): Failed to map the path '/'.


    I can browse the site just fine using http://locahost, but can't debug or build the site through Visual Studio without receiving the above error message.

    System Info:

    Windows 7 Ultimate 64
    IIS 7.5
    Visual Studio 2008 Professional

    Also worth noting I originally was running Vista Ultimate, and the web site ran without any issues (meaning I could build and debug). I've now upgraded my computer to W7 (fresh install) and am currently trying to reinstall/configure this site for local development. Any guidance you guys could give me on trying to track this down would be greatly appreciated.

     Thanks,

    Friday, July 9, 2010 12:01 AM

Answers

  • User-488364715 posted

    Ok, the error has magically disappeared. I'd love to tell you that I know exactly what I did to fix it, but I've tried so many things at this point that I don't know what actually solved the problem. I will say this...the last two things that I did was close Visual Studios and set it to always run as administrator (normally just right clisk and select run as) using the shortcut's properties. Then I started VS back up, and rather than launching my application from VS's recent projects list I manually navigated to the solution file and opened it directly. After that I was able to build the app without issue. Smile

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 9, 2010 2:05 AM

All replies

  • User2014649671 posted

    Hi, check your directory settings in IIS configuration manager. Seems it is not mapping the root directory properly.


    Ta,

    Friday, July 9, 2010 1:08 AM
  • User-488364715 posted

    Thanks for the feedback Mohammed. I'm still getting use to IIS 7.5, but I've combined over the site configuration and have not come across any issues, at least nothing that is just jumping out at me. I'm also not sure that the issue is on that end because I am able to browse the site without any problems. It is only when building or debugging the site in Visual Studio that the problem pops up.

    Is there maybe a specific setting that you were thinking of, or perhaps you might have another suggestion?

    Thanks again.


    Also, some additional info for anyone that feels up to helping me solve this puzzle...I have at least half a dozen other sites/applications running (meaning able to debug and build) on the same machine without issue.

    Friday, July 9, 2010 1:24 AM
  • User-488364715 posted

    Ok, the error has magically disappeared. I'd love to tell you that I know exactly what I did to fix it, but I've tried so many things at this point that I don't know what actually solved the problem. I will say this...the last two things that I did was close Visual Studios and set it to always run as administrator (normally just right clisk and select run as) using the shortcut's properties. Then I started VS back up, and rather than launching my application from VS's recent projects list I manually navigated to the solution file and opened it directly. After that I was able to build the app without issue. Smile

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, July 9, 2010 2:05 AM
  • User-1793618686 posted

    Took me a while to realise what was causing this error.

    When I experienced the same problem I was opening a website using 'File System' and choosing a mapped network drive.

    Using the full UNC path, such as \\WebServerName\DriveLetter$\inetpub\wwwroot, solved this for me.

    Wednesday, January 29, 2014 2:56 PM