locked
Stream Analytics taking so much time to process data RRS feed

  • Question

  • Hi everyone.

    I am doing some test on this architecture:

    IoT Hub -> Stream Analytics -> Azure Function

    The query on Stream Analytics is just "Select * Into AzureFunction From IotHub".

    This whole process is taking more than 6 seconds.

    I'm just passing a timestamp as data from a function connected to the IoTHub straight to Stream analytics then to Azure function.



    Do you have any solution for this? 

    Each of those components is really necessary.

    Saturday, January 25, 2020 12:33 PM

All replies

  • Hello,

    Streaming Units (SUs) represents the computing resources that are allocated to execute a Stream Analytics job. The higher the number of SUs, the more CPU and memory resources are allocated for your job. This capacity lets you focus on the query logic and abstracts the need to manage the hardware to run your Stream Analytics job in a timely manner.

    Try to increase the Streaming Units (SUs) and see if the process is taking lesser time.

    For more details, refer “Understand and adjust Streaming Units”.

    Hope this helps. Do let us know if you any further queries.

    ----------------------------------------------------------------------------------------

    Do click on "Mark as Answer" and Upvote on the post that helps you, this can be beneficial to other community members.

    Monday, January 27, 2020 7:55 AM
  • Hello,

    Just checking in to see if the above answer helped. If this answers your query, do click “Mark as Answer” and Up-Vote for the same. And, if you have any further query do let us know.

    Tuesday, January 28, 2020 11:17 AM
  • I tried increasing SUs but nothing changed.

    I'm also trying sending very few data to SA (just temperature every 15 seconds) and using just a very simple query like "Select * Into AzureFunction From IotHub".

    Can't get why it's taking that much time.

    I also tried creating a new one, nothing changed.

    Tuesday, January 28, 2020 12:48 PM