locked
not seeing forwarded trafic anymore RRS feed

  • Question

  • Hi,

    I have recently installed the SP1 beta version, and I am not seeing forwarded traffic
    anymore. My configuration has changed since then, thus it is surely not related
    with this install: I have 2 windows vista boxes, the first one having the second one
    as a gate, and the second one having a route to the network a.b.c.d/e. When the
    first one send a packet to a box in a.b.c.d/e, I actually see the packet being forwarded
    by using wireshark, but my notification routine plugged at forward layer is not called;
    neither are ip inbound and outbound.

    Are you aware of such an issue?

    Any help appreciated,

    Thanks
    Wednesday, January 9, 2008 7:52 AM

Answers

  •  

    Another thing to check is to see whether the callout driver is registered w/ the FWP_CALLOUT_FLAG_CONDITIONAL_ON_FLOW flag. This flag is not valid for FORWARD layer and could prevent packet classification.

     

    Biao.W.

    Thursday, January 17, 2008 7:59 PM

All replies

  • Is your FORWARD layer filter sitting at its own sublayer? Is the traffic being forwarded IPv4 or IPv6?

     

    Biao.W.

    Wednesday, January 9, 2008 8:41 PM
  • Hi,

    My callout is not sitting at its own sublayer, and the filtered
    traffic is IPV4.

    Thanks for helping,

    Thursday, January 10, 2008 7:50 AM
  • I have been adding my own sublayer, but dont see forwarded traffic.
    Any other idea?

    (thanks for pointing it might have been an issue)
    Thursday, January 10, 2008 10:02 AM
  • Have you enabled forwarding on your interface? If not you can do it through the netshell command:

     

    netsh int ipv4 set int "Local Area Connection" forwarding=enable

     

    thanks,

    anu

     

    Thursday, January 10, 2008 9:00 PM
  •  

    Another thing to check is to see whether the callout driver is registered w/ the FWP_CALLOUT_FLAG_CONDITIONAL_ON_FLOW flag. This flag is not valid for FORWARD layer and could prevent packet classification.

     

    Biao.W.

    Thursday, January 17, 2008 7:59 PM