locked
Overlapping Series in Range Charts in SSRS RRS feed

  • Question

  • Hi,

    I have a Range Chart as shown as shown below. I am trying to highlight the category group in any way possible.

    One solution is explained in the blog "Overlapping Charts in SSRS using Range Charts"

    http://road-blogs.blogspot.com/2012/03/overlapping-charts-in-ssrs-using-range.html

    But this is for bar chart. I have a range chart, can we implement similar solution for Range Charts?

    If not, is there any otherway we can highlight the category group?

    Thanks


    NC

    Friday, August 3, 2012 8:10 PM

Answers

  • Hi gownam,

    Sorry for the delay.

    Based on my test, if we add two fields in to the Values area in a Range chart, the series for the two fields wil be displayed alternately. That way, we are unable to set the overlapping by using the method provided in the blog. In this case, I am afraid the closet approach is to add a set of Bar chart type series and set the Bar chart type series as the innermost layer. Let's assume the three fields in your chart is "Year", "Quarter", and "Val". Then, you can refer to the steps below:

    1. Create a Rang Chart as the screenshot above shows.
    2. Right click the series in the Values area, change it to Bar Chart type.
    3. Right click the modified series, open the Properties window, set the "Category field" to "[Year]". Set the "Value field" like below:
      =Switch(Fields!Year.Value="2009", 50,Fields!Year.Value="2010",60,Fields!Year.Value="2011",75)
    4. In the Series Properties window, click the "Legend" tab, check the "Don't show this series in a legend" option.
    5. Click the Plus sign in the Values area and add Val field to the area.
    6. Right click the newly added series in the Values area, change it to Range Chart type.
    7. Open the Properties window of the new series, set the proper "Bottom value" and set the "Category field" to "[Year]".

    The screenshot below is for your reference:

    Hope this helps.

    Regards,
    Mike Yin


    Mike Yin

    TechNet Community Support

    • Marked as answer by gownam Monday, August 13, 2012 12:50 PM
    Friday, August 10, 2012 12:27 PM

All replies

  • Hi gownam,

    Sorry for the delay.

    Based on my test, if we add two fields in to the Values area in a Range chart, the series for the two fields wil be displayed alternately. That way, we are unable to set the overlapping by using the method provided in the blog. In this case, I am afraid the closet approach is to add a set of Bar chart type series and set the Bar chart type series as the innermost layer. Let's assume the three fields in your chart is "Year", "Quarter", and "Val". Then, you can refer to the steps below:

    1. Create a Rang Chart as the screenshot above shows.
    2. Right click the series in the Values area, change it to Bar Chart type.
    3. Right click the modified series, open the Properties window, set the "Category field" to "[Year]". Set the "Value field" like below:
      =Switch(Fields!Year.Value="2009", 50,Fields!Year.Value="2010",60,Fields!Year.Value="2011",75)
    4. In the Series Properties window, click the "Legend" tab, check the "Don't show this series in a legend" option.
    5. Click the Plus sign in the Values area and add Val field to the area.
    6. Right click the newly added series in the Values area, change it to Range Chart type.
    7. Open the Properties window of the new series, set the proper "Bottom value" and set the "Category field" to "[Year]".

    The screenshot below is for your reference:

    Hope this helps.

    Regards,
    Mike Yin


    Mike Yin

    TechNet Community Support

    • Marked as answer by gownam Monday, August 13, 2012 12:50 PM
    Friday, August 10, 2012 12:27 PM
  • Thanks. That works perfectly.

    NC

    Tuesday, September 18, 2012 7:06 PM