locked
Package 'Microsoft.VisualStudio.Xaml' has failed to load properly RRS feed

  • Question

  • I can't use WPF designer.
    I tried some commands to fix it ('devenv /resetskippkgs' & 'devenv /resetsettings') but nothing change.

    This is the complete error message
    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Package Load Failure

    Package 'Microsoft.VisualStudio.Xaml' has failed to load properly ( GUID = {E58C2A8B-BCC4-4559-AD59-D62EB6D58A22} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading.
    ---------------------------
    Yes   No  
    ---------------------------

    Some days ago WPF Designer worked correctly and I didn't install anything new on my pc.
    Can someone help me ?
    Many thanks
    claudio
    Sunday, May 4, 2008 10:41 AM

Answers

  • Its bizarre that it would suddenly stop working like that. Have you tried running setup->repair?

     

    Monday, May 5, 2008 4:25 PM

All replies

  • Its bizarre that it would suddenly stop working like that. Have you tried running setup->repair?

     

    Monday, May 5, 2008 4:25 PM
  • Ok , fixed.

    Many thanks

     

     

    Tuesday, May 13, 2008 10:13 AM
  • Cool. I'm glad that sorted it out

     

    Tuesday, May 13, 2008 11:09 PM
  • can u please tell me how did u repair it?

    thanx
    alen
    Wednesday, December 17, 2008 9:16 PM
  • I just installed Visual Studio 2008 for the first time and immediately got the same error. I tried repairing the installation but it did not help. How did you manage to resolve this issue?
    • Proposed as answer by amirhp Tuesday, January 26, 2010 6:51 PM
    Friday, January 16, 2009 11:09 PM
  • According to some of the forums I've been browsing, this error only really occurrs due to two reasons:
    1) Accidentally deleting / corrupting the Microsoft.VisualStudio.Xaml.dll file
    2) You are in the possesion of an illegal copy of Visual Studio

    in both cases replacing the dll seems to work


    Languages: Visual Basic, C, C++, Python,HTML
    Tuesday, February 17, 2009 8:54 PM
  • I have tried to repair my installation of C# which did not solve this problem.  Not sure how I could have deleted by accident and my copy is legal express version. So what are my options now? Should I uninstall and start over(VB,VC#,VC++)

    Thanks for your help!
    Wednesday, February 18, 2009 10:00 PM
  • Hi,

    I also facing the same issue in my system. I have removed trial version of Visual Studio 2008 and installed new Visual Studio 2008 package [Licensed version] in my machine. Tt was working fine trial version. After installing the licensed version I am facing this issue.

    P.S: I am developing WPF & Silverlight applications.

    Please help me to fix this issue.

    Prabu
    Tuesday, June 16, 2009 9:12 AM
  • Prabu.P

    Since you are developing Silverlight applications, I assume you are using the Silverlight 2 Tools for Visual Studio 2008 SP1? If so, I suggest you may be able to repair your installation by re-running the installer for the Silverlight Tools, which should refresh the necessary assemblies.

    If this does not work, please reply with the File Version of the Microsoft.VisualStudio.Xaml assembly (you can find this by going to your GAC folder e.g. c:\windows\assembly, finding the entry and right clicking - select Properties, then the version tab, and the file version will be at the top. It should be something like 9.0.30729.1

    Mark


    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Wednesday, June 17, 2009 8:16 PM
  • Where can you get a new copy of the dll? 

    I had installed Visual Studio Express VB in order to qualify for the competitive upgrade.  I purchased an upgrade copy of Visual Studio 2008 standard.  It found the Express installation and proceeded with the install.

    I have repaired the installation but am still getting the error whenever I open a file.

    I don't know what to do.  I think the file must be corrupted, but the repair did not fix it. I don't know how to get a clean copy.
    Wednesday, July 15, 2009 8:21 PM
  • @lynnephelps:

    if you have installed Visual Studio Express VB, then patched it to Service Pack 1, then installed Visual Studio 2008 standard RTM, you are in a broken state (you'll see package load failures for Microsoft.VisualStudio.Xaml when trying to open a WPF project XAML file).

    To fix the problem, you can run the standalone Visual Studio 2008 Service Pack 1 installer. This should leave both the Express SKU and the Standard SKU with a working WPF designer, service packed to SP1.

    Please let me know how you get on,

    Thanks
    Mark
    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Wednesday, July 15, 2009 8:27 PM
  • @lynnephelps:

    if you have installed Visual Studio Express VB, then patched it to Service Pack 1, then installed Visual Studio 2008 standard RTM, you are in a broken state (you'll see package load failures for Microsoft.VisualStudio.Xaml when trying to open a WPF project XAML file).

    To fix the problem, you can run the standalone Visual Studio 2008 Service Pack 1 installer. This should leave both the Express SKU and the Standard SKU with a working WPF designer, service packed to SP1.

    Please let me know how you get on,

    Thanks
    Mark
    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Hey, I was also facing this problem of having the error message earlier. After installing the Service Park 1 my problem is solved! Probably like what you said, it had to do with the express edition, I installed the Visual Studio Express C# earlier, uninstalled it and then installed the Visual Studio 2008.

    Thanks!
    Monday, July 27, 2009 9:19 AM
  • I am glad to hear that this helped you get past the problem state @yeeen!

    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Monday, July 27, 2009 7:40 PM
  • I have exactly the same problem. Directly after the first install I get this error:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Package Load Failure

    Package 'Microsoft.VisualStudio.Xaml' has failed to load properly ( GUID = {E58C2A8B-BCC4-4559-AD59-D62EB6D58A22} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading.


    Repairing Visual Studio 2008 Team Developer Edition, SP1 or .NET 3.5 SP1 doesn't fo the trick. The silverlight SDK is also installed. What else could I try?


    http://bitbonk.spaces.live.com
    Tuesday, July 28, 2009 7:09 AM
  • I too have just discovered this problem having not done any WPF projects for some months.

    Tried a repair of VC# - no change.

    I have only ever installed the Express versions of Visual Studio. Have checked the File Version of the Microsoft.VisualStudio.Xaml assembly , as sugested by Mark, and it is 9.0.30729.1.

    Should I delete this assembly and then do a repair of VC#?

    Peter
    Tuesday, July 28, 2009 10:54 PM
  • @bitbonk:

    Rather than using the repair option on SP1, please try downloading and running the standalone Visual Studio 2008 Service Pack 1 installer and then starting Visual Studio from a Visual Studio 2008 command prompt with the /resetskippkgs switch (open a Visual Studio 2008 command prompt and type devenv /resetskippkgs).

    @peterwt

    From the version number of the assembly , it looks like you have the SP1 version of the VC# package installed. Given you are still seeing a package load failure, your most likely productive next step since you are still seeing this issue is to completely uninstall VC# Express, download a fresh copy from the internet, and completely re-install it.

    Mark
    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Wednesday, July 29, 2009 1:20 AM
  • Thanks Mark - that's what I will do.

    Peter
    • Proposed as answer by peterwt Wednesday, July 29, 2009 9:47 AM
    Wednesday, July 29, 2009 9:47 AM
  • Finlly I got my VS IDE's XAML intelligence after installing "Microsoft Visual Studio 2008 Service Pack 1" downloaded from the given link.

    http://download.microsoft.com/download/a/3/7/a371b6d1-fc5e-44f7-914c-cb452b4043a9/VS2008SP1ENUX1512962.iso

    Alternate solution:-
    If you change your machine's user profile, then there might be a change to get the XAML intelligence.
    Prabu
    Wednesday, July 29, 2009 1:31 PM
  • Uninstall/install cured the problem.

    I think the Microsoft.VisualStudio.Xaml package must have got corrupted.

    Peter
    • Proposed as answer by peterwt Monday, August 31, 2009 10:40 PM
    Wednesday, July 29, 2009 2:34 PM
  • Since in my case un/installing SP1 (neither as standalone nor as web installer) or un/installing VS 2008 (Team Developer Edition) did not I'd like to share the solution that worked for me:

    I uninstalled all Microsoft Products that are related to XAML and/or Visual Studio 2008:

    - Silverlight 3
    - Silverlight 3 SDK
    - Expression Studio 3 (all components)
    - Visual Studio 2008 Team Developer Edition
    - Team Foundation Client 2008

    Once all this is uninstallled the GAC should not contain Microsoft.VisualStudio.Xaml anymore. If you have some Visual Studio 2008 Express Editions installed, uninstall them too. If then Microsoft.VisualStudio.Xaml is still in the GAC I think you are safe to uninstall it from the GAC.

    Then I reinstalled everything including VS 2008 SP1.

    And it worked. Intellisense is back. I wish I knew what caused this. How can Microsoft.VisualStudio.Xaml get corrupted once it is in the GAC?

    http://bitbonk.spaces.live.com
    • Edited by bitbonk Wednesday, July 29, 2009 6:53 PM
    Wednesday, July 29, 2009 6:28 PM
  • @bitbonk, thanks for posting your solution and I'm glad that it worked.

    Several installers install the Microsoft.VisualStudio.xaml assembly, and it is possible that you might have run into an install order issue.

    If you install the Silverlight 3 Tools for Visual Studio 2008, in order to provide the Silverlight functionality we have to revise the Microsoft.VisualStudio.Xaml assembly. This means that if you're using Silverlight Tools you need to ensure they are installed last, so the order would be:

    1. Install RTM Visual Studio 2008 bits
    2. Install Visual Studio 2008 SP1
    3. Install Visual Studio Tools for Silverlight 3

    If you reverse 2,3 the installer may not correctly detect the situation and you might get into a state where a mismatched version of the assembly is in the GAC and won't load (causing the package load failure).

    Note
    This set of instructions doesn't cover the case where you have Express editions installed alongside a paying edition of Visual Studio such as Visual Studio Pro, Developer Edition etc. If you have installed Express editions alongside a paying edition, your situation will vary depending on whether they have been updated to Service Pack 1 prior to installing the paying edition or not.  You'll need to install service pack 1 again to make the paying edition work if you've SP'd your express edition prior to installing a paying edition. However you'll still need to install Silverlight Tools LAST.

    Mark


    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Wednesday, July 29, 2009 8:24 PM
  • I think we all agree that this is a mess (and needs to be adressed, at least for future versions).

    http://www.google.com/webhp?hl=en#hl=en&q=microsoft.visualstudio.xaml&aq=0p&oq=mic&aqi=g-p3g7&fp=JXEMTJqWKpI




    http://bitbonk.spaces.live.com
    Wednesday, July 29, 2009 9:00 PM
  • Wow!! Looking at bitbonk's google link this seems to have been a big problem.

    Peter
    Thursday, July 30, 2009 8:33 AM
  • For those of you out there having this problem, I was also having the same problem with my Intellisense and XAML after installing the Silverlight and Expression tools v3.

    I was able to get mine working by simply following the instructions in the error message.

    1.  Close Visual Studio 2008
    2.  Open the development environment command prompt (Start, All Programs, Microsoft Visual Studio 2008, Visual Studio 2008 Tools, Visual Studio 2008 Command Prompt)
    3.  Issue the following command at the prompt : devenv /resetskippkgs

    After that IS is working like a champ... so it does work -- sometimes!

    Hope it works for you too.

    Good luck!

    Drew Matalus
    • Edited by dmatalus Monday, August 31, 2009 9:10 PM Correction
    • Proposed as answer by Suma5566 Tuesday, August 31, 2010 3:43 AM
    Monday, August 31, 2009 9:08 PM
  • Hi everyone!

    I had the same problem after installing VS 2008 (team suite) + sp1 (no other products were installed). Repairing installation and re-installing sp1 does not helped me. What worked for me, was extracting these dll's (coping them from explorer) from GAC (c:\WINDOWS\assembly\GAC_MSIL) and adding them back through .Net framework configuration mmc.


    Microsoft.VisualStudio.Xaml
    Microsoft.Windows.Design
    Microsoft.Windows.Design.Developer
    Microsoft.Windows.Design.Extensibility
    Microsoft.Windows.Design.Host
    Microsoft.Windows.Design.Interaction
    Microsoft.Windows.Design.Markup
    Tuesday, October 20, 2009 4:05 PM

  • Disso said:
    I just installed Visual Studio 2008 for the first time and immediately got the same error. I tried repairing the installation but it did not help. How did you manage to resolve this issue?


    I had exactly the same problem but when I ran the following command it solves it:

    C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE>devenv /resetskippkgs
    Tuesday, January 26, 2010 6:49 PM
  • I had exactly the same problem but when I ran the following command it solves it:

    C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE>devenv /resetskippkgs
    Tuesday, January 26, 2010 6:52 PM
  • I have the same problem. When starting VisualStudio 2008 prof:

    Package 'Microsoft.VisualStudio.Xaml' has failed to load properly ( GUID = {E58C2A8B-BCC4-4559-AD59-D62EB6D58A22} ). Please contact package...

     

    I have seen through mmc that my assemblies have different languages. Could that be the problem? What should I do?

    (GAC) Microsoft.VisualStudio.Xaml    9.0.0.0    neutral    b03f5f7f11d50a3a
    (GAC) Microsoft.VisualStudio.Xaml.LanguageService    9.0.0.0    neutral    b03f5f7f11d50a3a
    (ZAP) Microsoft.VisualStudio.Xaml.LanguageService    9.0.0.0    neutral    b03f5f7f11d50a3a
    (GAC) Microsoft.VisualStudio.Xaml.LanguageService.resources    9.0.0.0    de    b03f5f7f11d50a3a
    (ZAP) Microsoft.VisualStudio.Xaml.LanguageService.resources    9.0.0.0    de    b03f5f7f11d50a3a
    (GAC) Microsoft.VisualStudio.Xaml.resources    9.0.0.0    de    b03f5f7f11d50a3a


    Eugen Wiebe
    • Proposed as answer by mauriciohz Thursday, November 15, 2012 2:51 PM
    Thursday, April 22, 2010 10:08 AM
  • Hi @Eugen Wiebe

    Have you tried (re) installing Visual Studio 2008 SP1 ?

    See http://blogs.msdn.com/wpfsldesigner/pages/VS2008FAQ.aspx Item 3 for details.

    Thanks

    Mark


    Mark Wilson-Thomas - Program Team - WPF & SL Designer for Visual Studio - posts are provided 'as-is'
    Thursday, April 22, 2010 4:36 PM
  • For those of you out there having this problem, I was also having the same problem with my Intellisense and XAML after installing the Silverlight and Expression tools v3.

    I was able to get mine working by simply following the instructions in the error message.

    1.  Close Visual Studio 2008
    2.  Open the development environment command prompt (Start, All Programs, Microsoft Visual Studio 2008, Visual Studio 2008 Tools, Visual Studio 2008 Command Prompt)
    3.  Issue the following command at the prompt : devenv /resetskippkgs

    After that IS is working like a champ... so it does work -- sometimes!

    Hope it works for you too.

    Good luck!

    Drew Matalus


    i Love you man, IT JUST WORKS!!!

     

    Many Thanks :)

    Tuesday, August 31, 2010 3:44 AM
  • dmatalus suggestion worked for me. All i did extra is opening Visual Studio 2008 Command Prompt as 'Administrator' as am using Windows 7 Ultimate. Thanks once again to Dmatalus

    rams

    Tuesday, June 7, 2011 7:27 AM
  • I had the same problem after installing Intel IPP 7.0. Installed the VC2008 SP1 update and it fixed that problem but now I get an error about loading Intel.CommonTools.IntelCommonPkg (but at least I can compile and link the code). Will try to resolve that one tomorrow...
    Al Chisholm
    Wednesday, December 14, 2011 10:22 PM