none
.NET framework troubles 3.5 and others. RRS feed

  • Question



  • I was trying to use Magic Online when I opened it I got this error "To run this application you must first install one of the following versions of the .NET Framework: v4.0.30319"  I am on Windows Vista home premium 64 bit, service pack two. I immediately installed all updates from Windows updates to being my .NET up to date however I got an "Error 643" on this update "Microsoft .NET framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847)" So I went to a linked Blog from Microsoft which told me I needed to uninstall my .NET frameworks and reinstall them in order after I uninstalled them and tried to reinstall them. None of them worked and an example of one of the errors the log looked like this: 


    OS Version = 6.0.6002, Platform 2, Service Pack 2

    OS Description = <st1:place>Vista</st1:place>- x64 Home Premium Edition Service Pack 2

    CommandLine = C:\56076851c740e6fa8945c13ea3a9f3\\Setup.exe /x86 /x64 /ia64 /web
    TimeZone = Pacific Standard Time
    Initial LCID = 1033

    Using Simultaneous Download and Install mechanism

    Operation: Installing

    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319

    User Experience Data Collection Policy: Disabled

    Number of applicable items: 12

    Exe (C:\56076851c740e6fa8945c13ea3a9f3\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt

    ServiceControl operation succeeded!

    ServiceControl operation succeeded!

    Exe (C:\Users\Ethan\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.0-KB956250-v6001-x64.msu) failed with 0x1 - Incorrect function. .

    Exe (C:\56076851c740e6fa8945c13ea3a9f3\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt

    MSI (C:\Users\Ethan\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120208_102311375-MSI_netfx_Core_x64.msi.txt

    Exe (C:\56076851c740e6fa8945c13ea3a9f3\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt

    MSI (C:\Users\Ethan\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120208_102311375-MSI_netfx_Core_x64.msi.txt

    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 <st1:time hour="0" minute="2">00:02:02</st1:time>).


    This is an example of one of the errors but they all did not work I would appreciate any help. 

    Wednesday, February 8, 2012 6:33 PM

Answers

All replies

  • I'm not sure what blog you read that advised removing all .NET Frameworks from a Windows version that includes .NET Framework 2.0/3.0 as part of the OS, but that advice is misguided.

    First, you cannot remove embedded frameworks from you system!

    Based on what you attempted, you may have corrupted you OS. So, lets first see if your embedded frameworks are OK. Use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx 

    Run the tool twice, once for 2.0, once for 3.0. Post the first 15 lines and the last 15 lines of tool output here.

    If the verifier finds issues with your embedded frameworks, you will need to use this procedure to attempt repair:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx 

    If you cannot repair successfully, an OS reinstall is needed.

    If your embedded frameworks are OK, then you should follow these steps exactly:

    1. Download a fresh copy of the standalone cumulative update for .NET Framework 3.5 (this includes 2.0 and 3.0 SP's):

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    2. Clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&amp;displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Wednesday, February 8, 2012 8:06 PM
  • First off,  thank you so much for your help. Your instructions are 10 times more clear and 100 times more helpful then both gateway and microsofts phone customer services. I ran the verifier on both 2.0 and 3.0 and they were both fine so I did not post the first and last 15 lines if you still need them I will post them though. 
    My install of Net Framework 3.5 failed and here is a link to my vslogs on skydrive it seemed like a lot of stuff.

    https://skydrive.live.com/redir.aspx?cid=9c21e922ef8104c9&resid=9C21E922EF8104C9!141&parid=9C21E922EF8104C9!131&authkey=!AFc6GTRL1P-b1Rw

    Sorry for my late reply I didn't expect to be answered so soon. If I didn't so something right let me know how I can best help you help me. Thanks Again 
    CCP

    CCP 2010

    Saturday, February 11, 2012 8:21 PM
  • From your install log:

    "Product: Microsoft .NET Framework 3.5 SP1 -- Error 1719.The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed."

    You have a Windows Installer issue. This thread has procedures in the answers and other posts you should follow:

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/b16815f0-e560-4a42-81d2-978614468e30 

    You can also try the fix in the answer in this thread:

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/07756ca6-eb0b-4c3f-85ee-035cb8296384


    • Edited by pvdg42 Saturday, February 11, 2012 11:49 PM
    • Marked as answer by Barry WangModerator Thursday, February 23, 2012 6:54 AM
    Saturday, February 11, 2012 11:48 PM