locked
IE11 http request header always has X-UA-Compatible: IE=EmulateIE7 RRS feed

  • Question

  • User617038525 posted

    hi,

    I am accessing an intranet site with IE11  WITHOUT  a compatibility view but the page always renders in IE7 mode. I noticed through fiddler that the request header always has X-UA-Compatible: IE=EmulateIE7 which leads to the response header also always having X-UA-Compatible: IE=EmulateIE7. Can anybody tell me why the request header always includes X-UA-Compatible: IE=EmulateIE7 which I'm suspecting is the reason why IE11 always falls back on IE7?

    THanks

    Tuesday, July 15, 2014 4:00 PM

Answers

  • User465171450 posted

    Did you also verify it isn't set on a global level with the server? I forgot to mention that you can define it for the entire IIS server, then it can also be defined on a per virtual server instance.

    Additionally, do you have any custom javascripts included in the page that may be adding this dynamically without knowing since it wouldn't have to be in the page/masterpages markup?

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 16, 2014 2:07 PM
  • User617038525 posted

    Yes I did check that it is not set at the global level in iis. But I should say that my page is served from inside the cms plumtree. I did test where the page is not embedded in plumtree and everything works fine. So it might be that somehow plumtree is adding this setting dynamically. Thanks anyway for your help.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 16, 2014 2:56 PM

All replies

  • User465171450 posted

    Have you checked to ensure that IIS itself hasn't been set to add this header in the Http Response Headers section of the IIS features group for the site?

    Tuesday, July 15, 2014 5:12 PM
  • User-166373564 posted

    Hi

    I am accessing an intranet site with IE11  WITHOUT  a compatibility view but the page always renders in IE7 mode.

    If you use IIS 7 on your side, go to the site and click on “HTTP Response Headers”, just go to the site and click on “HTTP Response Headers”. Such as:

    Regards

    Angie 

    Wednesday, July 16, 2014 1:34 AM
  • User617038525 posted

    Yes I checked that IIS is not set to add this header. In fact I did an experiement with IIS where I set this header to IE11 but still if falls back to IE7. I have no clue where the response X-UA-Compatible: IE=EmulateIE7 is coming from. Any other ideas please? 

    Wednesday, July 16, 2014 9:02 AM
  • User617038525 posted

    I did that Angie where I set X-UA-Compatible to IE11 but still my IE11 browser falls back on IE7. Any other ideas please? 

    Wednesday, July 16, 2014 9:04 AM
  • User465171450 posted

    Did you also verify it isn't set on a global level with the server? I forgot to mention that you can define it for the entire IIS server, then it can also be defined on a per virtual server instance.

    Additionally, do you have any custom javascripts included in the page that may be adding this dynamically without knowing since it wouldn't have to be in the page/masterpages markup?

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 16, 2014 2:07 PM
  • User617038525 posted

    Yes I did check that it is not set at the global level in iis. But I should say that my page is served from inside the cms plumtree. I did test where the page is not embedded in plumtree and everything works fine. So it might be that somehow plumtree is adding this setting dynamically. Thanks anyway for your help.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 16, 2014 2:56 PM