none
Insufficient frame rate 0-10FPS Depth and color streams RRS feed

  • Question

  • Can somebody help me overcome my Depth and color streams problem 

    I don't know why I am getting around 5-10FPS with my kinect

    I have a relatively decant system specs:

    ryzen 5 2600

    RTX 2060

    16gb ram 

    I have also installed all the drivers that was needed for my kinect

    Thanks

    Wednesday, September 25, 2019 2:20 PM

All replies

  • JoeyOxO -

    Do you have any other devices plugged into the same USB3 controller that might be making heavy use of the bus?  That can cause the frame rate of the Kinect to drop.

    Bryan

    Thursday, September 26, 2019 6:54 AM
    Moderator
  • I was having around 12fps with my Kinect sensor on my Ryzen 9 3900X / RX 5700XT system. I unplugged from one of the USB 3.0 ports on the back of the mainboard, and plugged into a different one, and now I am getting 30fps. One set of USB ports was red, and the other was blue. I plugged into a port marked as "VR Ready" and it's working great. I think I may have been plugged into a USB port that connected through the chipset, which could have added extra latency.
    • Proposed as answer by Toulji Tuesday, March 31, 2020 11:00 PM
    Sunday, March 15, 2020 8:08 PM
  • I was having a very similar issue. My PC setup is nearly identical to that of the poster. 

    I unplugged all USB devices (except for keyboard and mouse) and then tried the kinect. Voila, no more issues. Plugging everything back in didn't make any difference afterwards, it seems to work fine now. 

    Tuesday, March 31, 2020 11:02 PM