locked
HTC 8X with 8.1 preview not connecting to any Wi-Fi after power cycle RRS feed

  • Question

  • Turned every option on/off one at a time and in combinations still will not connect to WiFi. These options were Airplane mode, Sharing, Data, etc. As listed above in the many, many posts.

    I had no problems at all with the developer update until last Thursday when I had to power cycle my phone. It quit sending text messages is the reason I powered cycled my phone. I did NOT do a hard reset just a simple power down and powered back on, which I have done many times with no problem until now.

    I have two HTC 8X phones. One with the 8.1 developer and one with what it came with 8.0

    The 8.0 works flawlessly while the 8.1 obviously does not. I went through every setting. best you can, between the 2 and made sure they were set up the same but still no WiFi connection. It sees the WiFi and asks for passwords but it just will not connect.

    Actual error message is : Can't Connect Your phone can't connect to the Wi-Fi network  

    I have since done several Hard Resets sometimes using a back up sometimes starting fresh but nothing helps.

    Listed below are the 2 HTC 8X phones I have. The 8.0 works the 8.1 does not.

    HTC8X                                                   HTC8X

    Model:                                   HTC HTC6990LVW                            HTC HTC6990LVW

    Software:                               Windows Phone 8.0                       Windows Phone 8.1

    Screen Resolution:                  720x1280                                             720x1280

    OS version:                            8.0.10501.127                                     8.10.12359.845

    Firmware version:                   3030.0.41301.605                              3030.0.41301.605

    Hardware version:                   0002                                                       0002

    Radio software version:            0.17.50.0918_3                                  0.17.50.0918_3

    Radio Hardware version:           2.126.3.D4                                           2.126.3.D4

    Bootloader version:                  0.0.3030.0(176844)                         0.0.3030.0(176844)

    Chip SOC version:                    8960                                                      8960

    Hope this gets fixed soon as it is my opinion a SMART phone without Wi-Fi is a dumb phone and useless.

    Thursday, May 8, 2014 3:48 AM

All replies

  • I'm having the same issue.
    Saturday, May 10, 2014 2:43 AM
  • I'm hitting the same wifi problems on a Lumia 920.
    Saturday, May 10, 2014 7:36 AM
  • Hello Foreseer,
    Can you please update to the latest version that was released yesterday and see if you continue to see this issue?

    Thank you,
    Eli A.


    Windows Phone Support - Support Delivery Manager

    Thursday, May 15, 2014 4:40 PM
  • I tried after the patch last night. It still repros.
    Thursday, May 15, 2014 9:04 PM
  • Downloaded and still have the same problem. Went through all the steps I tried before and it will not connect to any WiFi.
    Friday, May 16, 2014 10:54 AM
  • Hello All:

    Thank you for the continued follow up.  I wanted to bump this thread and continue to ask for feedback from anyone that is still having issues connecting via WiFi after the recent update.  Please be sure to vote for the thread and provide the following details.

    • Make and model of phone.
    • Current OS version.
    • Current firmware revision.
    • How many WiFi networks have you attempted to connect to?
    • What security is on this WiFi; WEP, WPA, WPA2, None, other?
    • Country you are located in.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Monday, May 19, 2014 6:04 AM
    Moderator
    • HTC 8X HTC HTC6990LVW
    • 8.10.12382.878
    • 3030.0.41301.605
    • 6
    • WPA2
    • USA
    • Edited by foreseer Monday, May 19, 2014 10:01 PM Typo
    • Proposed as answer by withy1 Tuesday, May 20, 2014 12:09 AM
    • Unproposed as answer by withy1 Tuesday, May 20, 2014 12:09 AM
    Monday, May 19, 2014 9:58 PM
  • Lumis

    8.10.12382.878

    3051.40000.1345.1007

    2

    WPA2

    Australia

    Tuesday, May 20, 2014 12:12 AM
  • HTC 8x

    OSver: 8.10.12382.878

    Firmware: 3030.0.34101.531

    How many WiFi networks have you attempted to connect to? A dozen or so. Some work (notably the network where I work)

    • What security is on this WiFi; WEP, WPA, WPA2, None, other? I've tried both WPA2 and none.
    • Country you are located in: USA

    Tuesday, May 20, 2014 12:14 AM
  • Any news yet? Still trying everything and nothing works to connect. I have tried with different securyties and still nothing.


    Mark T Davis


    • Edited by foreseer Sunday, June 15, 2014 2:40 AM
    Thursday, May 22, 2014 6:46 PM
  • Hello All:

    Thank you for the feedback.  From the information provided here it looks like this could be related to the security on the networks you are trying to connect to.  If you have not already tried connecting to an unsecured network or one that is running something other then WPA2, please try this.

    Otherwise, my only other thought is that this may be related to some firmware issue.  The preview did not come with any firmware updates so this is something that might be resolved when the official release comes out. 

    For anyone else with this issue, please provide the requested details and do not forget to vote for this thread.

    Mark W.

    Monday, May 26, 2014 4:18 AM
    Moderator
  • George Holt said earlier that the issue repros on secured and unsecured networks, but that WiFi works on his work network (@microsoft).
    Monday, May 26, 2014 7:03 AM
  • Still absolutely not connecting to any Wi-Fi, at home, at work, on the road regardless of any type of security and even no security at all.

    I am confused as to why this seems to be a firmware issue when the firmware did not change just the OS. Did someone not do their homework?

    And, why do others that I know with the exact same phone I have (HTC 8X) have absolutely no problem after installing the dev preview?


    Mark T Davis


    • Edited by foreseer Sunday, June 15, 2014 2:40 AM
    Tuesday, May 27, 2014 9:26 PM
  • I am having the same issue with HTC 8X with developer preview 8.1

    It worked at first, then after a phone reset it stopped working. I have tried on both secured and non-secured WiFi hotspots. I have a Lumia 920 that has the developer preview 8.1 and it's currently working, and I don't want to restart to test if that's the issue because then I will have 2 useless phones. Neither phone has carriers (they are used for debugging and testing) so without WiFi there is no way to update the software.

    The phone can see all the networks, but they all show "No Internet Connection" when you try to connect. And if you connect anyways, it says "No Internet Access"

    Wednesday, May 28, 2014 7:11 PM
  • Hello All:

    Thank you for the feedback and continue to provide us the requested details.  I will be having this sent on for further review.

    The reason I referenced the firmware is that this is clearly not a full blown OS issue as very few seem to be impacted.  As most of you have referenced, this does seem to be specific to certain phones as you or someone you know has a phone running the preview and encounters no connection issues. 

    If any Nokia users have the Nokia software suite and are familiar with the process to reinstall a previous OS and firmware, I would be interested to know if doing this and then reinstalling the preview corrects the issue.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Friday, May 30, 2014 4:35 AM
    Moderator
  • After installing the latest DPP update for 8.1 neither of my 2 Lumia ICONs will connect to my home wifi. I have other devices connected to the network, and nothing has changed with the wifi setup, so I'm sure this is an issue with the OS and/or the OS running on an ICON. I've done a hard reset of one of the phones and am getting the same error. Full error: Can't connect. Your phone can't connect to the Wi-Fi network..."
    Saturday, May 31, 2014 8:59 PM
  • My wife and I are having the same issue on two Nokia Icons at both home and work.  The message I'm getting is "Your phone can't connect to the Wi-Fi network".  Turning wifi off and on doesn't solve the problem.  I've had some limited success rebooting my phone and being able to connect to the same wifi that was previously giving me an error. 

    OS: 8.10.12393.890

    Monday, June 9, 2014 2:02 PM
  • Getting the same issue just this morning with my Nokia 920. I get the same message of "Your device can't connect to the Wi-Fi network <NetworkName>". I tried to see when the last time my device checked for an update but under Phone Update was only able to see it couldn't check the last time it tried.

    Currently running:

    OS version 8.10.12382.878

    Firmware rev:3051.40000.1347.1001

    on At&t in Washington state


    A world of code

    Tuesday, June 10, 2014 2:01 PM
  • Hello? Anyone even looking at this?

    With no way of reverting my HTC8X back to 8.0 I am stuck with, more or less, a BRICK that I have to pay for monthly.

    In no way is this a Firmware issue.

    In no way is this an isolated event.

    In no way should it take this long to correct.

    Guess it is too hard to look at the code that was changed.

    Sorry to sound aggravated but I think enough time has passed to correct the ongoing problem. May 8th was original post date.

    Thank God it's not a destructive virus.


    Mark T Davis




    • Edited by foreseer Saturday, June 21, 2014 11:50 PM
    Sunday, June 15, 2014 2:39 AM
  • Hello Folks,
    We are checking to see if the latest update to the preview program has resolved this issue for your devices.  In addition, can you also please confirm the mobile operator of your device?

    We are still investigating this issue further, and do not have any further updates at this time.

    Thank you,
    Eli A. 


    Windows Phone Support - Support Delivery Manager

    Tuesday, June 17, 2014 3:47 PM
  • Verizon is my carrier

    OS version now is 8.10.12397.895


    Mark T Davis


    • Edited by foreseer Thursday, June 26, 2014 9:19 AM
    Saturday, June 21, 2014 11:50 PM
  • Any news yet? Data only is not good on the wallet.

    Anyone here get their Wi-Fi working yet?

    Countless resets, countless hours of turning options on then off then on again, reboot after reboot after reboot and still NO WI-FI.

    Once again:

    Model : HTC69906VW (HTC 8X)

    OS Version : 8.10.12397.895

    Firmware Version : 3030.0.41301.605

    Hardware Version : 0002

    Radio Software Version : 0.17.50.0918_3

    Radio Hardware Version : 2.126.3.D4

    Bootloader Version : 0.0.3030.0(176844)

    Chip SOC Version : 8960

    Carrier : Verizon

    Country : USA - North Carolina


    Mark T Davis



    • Edited by foreseer Thursday, June 26, 2014 9:20 AM
    Thursday, June 26, 2014 9:17 AM
  • Wi-Fi seems fine now.

    OK. Just a quick update for anyone still reading this thread as it seems MS is not!

    I took my other HTC8x that still has 8.0 and works flawlessly (other than the cracked screen) and installed the 8.1 developer preview. I did ALL the updates, as there were several, rebooted the phone and it still works flawlessly.

    I then put both phones side by side, confirmed they were both using the latest OS, firmware, etc. and proceeded to go through every setting one at a time to ensure both were set up the same. I mean something had to be different for one to work and the other not right?

    Here is what I found. On one phone the VPN was OFF and on one phone the VPN was ON. I do not use this feature but found it odd that they were different. So, I turn ON the VPN without setting it up and the Clouds parted and the Heavens sang. I now have Wi-Fi on both phones.

    Geesh, weeks of frustration, hard resets, re-downloading everything using data out the wazoo and all because of a simple setting that I have no idea why it affected Wi-Fi. It boggles the mind how different items affect each other.

    For now all is well.


    Mark T Davis


    • Edited by foreseer Monday, June 30, 2014 2:48 PM
    Monday, June 30, 2014 2:48 PM
  • Another day another update.

    No more Wi-Fi. Went outside to work on my deck, left my phone inside on my desk, came back in when I was finished and NO WI-FI AGAIN.

    Went through all the steps again but to no avail. The "fruit" company is looking better all the time.

    Real embarrassing that I am the only MS phone where I work and get laughed at because my phone can't do what theirs does on MS servers.


    Mark T Davis


    • Edited by foreseer Tuesday, July 1, 2014 3:52 PM
    Tuesday, July 1, 2014 3:52 PM
  • More than two months later, I'm still broken. 

    Fortunately I'm grandfathered into an unlimited data plan.

    Unfortunately, 4g is still much slower than Wi-fi.

    Tuesday, July 22, 2014 5:03 PM