locked
TFS 2008 - VS.NET 2008 CheckIn \CheckOut guidance needed RRS feed

  • General discussion

  • Our developers brought this to my attention. DevA would create a VS.NET C# Solution and add the entire Solution to TFS.  DevB would check out that Solution, modify some code, then check it back in. Then DevA (who has an older version of the source code in his local workspace) would modify the source code in their local workspace.

    Per the developers, when DevA began editing a file under TFS 2005 source control a message would appear indicating the source files would be checked out for them automatically and a "get latest" would be done too.

    Per the developers under TFS 2008 the behaviour has changed. Editing a source file in their workspace does not always cause an automatic checkout and even using Get Latest from VS..NET does not always retrieve the latest version from Source control.  They claim this "problem" is intermittent.

    What is the expected behaviour under TFS 2008? (I never used TFS 2005 enough tp know how it behaved under similar circumstances.)

    TIA,

    Barkingdog

    Wednesday, November 10, 2010 12:29 AM

All replies

  • The default setting in TFS 2008 (and TFS 2010) is to _not_ perform a get latest when checking out. This can be changed using Team Explorer (Team project -> Team Project Settings -> Source Control -> Enable get latest on check-out"

    Although it can be done, it generally is not recommended to use this feature. The problem is that it is not related to changesets as a whole, but to individual files. This means that if user A checks in a changeset containing 2 modified file, and then user B starts to edit one of those files, he would get the latest version of that file but not the other one that was part of the original changeset.

    TFS has great merging capabilities, so work in parallell without doing a get latest, and then resolve any merge conflict at check-in time

    Hope that helps
    /Jakob


    Blog: http://geekswithblogs.net/jakob Twitter: http://twitter.com/osirisjakob
    Wednesday, November 10, 2010 9:46 AM