none
Error_1_Required service 'Microsoft.VisualStudio.Tools.Applications.Runtime.IHostItemProvider' was not available. RRS feed

  • Question

  • I have built a new Excel workbook application in VS 2008 on a windows vista machine with Office 2007 on it.  I selected an existing Excel workbook to start with.  From the beginning it failed every time i tried to add a button to a spreadsheet. I decided to reboot and then reopen the project.  Upon reopening it said the workbook couldn't be accessed because it was in use.  I opened excel and closed it and it said the workbook in question was open, so I chose to close it without saving.  In VS I then tried to click on a worksheet and suddenly the error given here appeared:

    Error    1    Required service 'Microsoft.VisualStudio.Tools.Applications.Runtime.IHostItemProvider' was not available.        0    0   

     

    Something feels very wrong...

     

    any ideas appreciated.

     

    ps: only office 2007 is on this machine.

    anton

     

     


    Thursday, June 30, 2011 6:23 AM

Answers

  • Hi Tom,

     

    After much ado I have got it all working - as you suggested, on another machine.  I un-installed everything and re-installed office 2007 and VB studios 2008. 

     

    I did the same with office 2003 and this time I updated the service pack for it and....

     

    it all worked.

     

    Thanks


    Anton
    Thursday, July 14, 2011 10:12 PM

All replies

  • Hi SydneyWaterBoy,

     

    Thanks for posting in the MSDN Forum.

     

    I would recommend you reproduce your issue on other computers which has similar environment(Vista, Visual Studio 2008, Office 2007) to see whether it will be occurred.

     

    It’s based on my experience that your issue will be occurred due to specific setting of your computer, and it will not be occurred everywhere.

     

    Let’s do trouble shooting to find out what affect the Visual Studio work well.

     

    Have a good day,

     

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, July 4, 2011 5:40 AM
    Moderator
  • Hi Tom,

     

    After much ado I have got it all working - as you suggested, on another machine.  I un-installed everything and re-installed office 2007 and VB studios 2008. 

     

    I did the same with office 2003 and this time I updated the service pack for it and....

     

    it all worked.

     

    Thanks


    Anton
    Thursday, July 14, 2011 10:12 PM