locked
.NET 3.5 installation problem RRS feed

  • Question

  • Hello, I've been trying to install Visual Studio Express 2008 on Windows XP Professional SP2 but it fails at the .NET 3.5 install. I've followed everything I could find to no avail. This includes trying to install it outside the VS installation, increasing the log verbosity and searching for "return value 3", uninstalling all .NET CLRs, using Windows Installer cleanup, even looking in the registry. I still get a 1603 saying 3.0a could not be found or something. To answer the starting point questions:

    Where'd I get it?
    http://www.microsoft.com/downloads/details.aspx?FamilyID=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en

    Any .NET patches?
    No.

    What version?
    3.5 standard release


    Friday, February 8, 2008 10:45 PM

Answers

  •  

    Hi David,

     

    Thanks for sending your logs.  Here's the relevant portion:

     

    Code Snippet

    MSI (s) (30:24) [14:04:42:437]: Assembly Error:Function not defined in specified DLL.

    MSI (s) (30:24) [14:04:42:437]: Note: 1: 1935 2: {06E55FA7-ED36-4A74-8C82-F3D505C50F2E} 3: 0x8002802F 4:  5: CreateAssemblyNameObject 6: System.ServiceModel.WasHosting,Version="3.0.0.0",Culture="neutral",PublicKeyToken="b77a5c561934e089",ProcessorArchitecture="MSIL",FileVersion="3.0.4506.648"
    MSI (s) (30:24) [14:04:42:437]: Product: Microsoft .NET Framework 3.0 Service Pack 1 -- Error 1935.An error occured during the installation of assembly component {06E55FA7-ED36-4A74-8C82-F3D505C50F2E}. HRESULT: 0x8002802F. assembly interface: , function: CreateAssemblyNameObject, assembly name: System.ServiceModel.WasHosting,Version="3.0.0.0",Culture="neutral",PublicKeyToken="b77a5c561934e089",ProcessorArchitecture="MSIL",FileVersion="3.0.4506.648"

    Error 1935.An error occured during the installation of assembly component {06E55FA7-ED36-4A74-8C82-F3D505C50F2E}. HRESULT: 0x8002802F. assembly interface: , function: CreateAssemblyNameObject, assembly name: System.ServiceModel.WasHosting,Version="3.0.0.0",Culture="neutral",PublicKeyToken="b77a5c561934e089",ProcessorArchitecture="MSIL",FileVersion="3.0.4506.648"
    MSI (s) (30:24) [14:04:42:453]: User policy value 'DisableRollback' is 0
    MSI (s) (30:24) [14:04:42:453]: Machine policy value 'DisableRollback' is 0
    Action ended 14:04:42: InstallExecute. Return value 3.

     

     

    Aaron Stebner has a blog post on this particular error message and error code, so I'd suggest looking at this post to see if it will resolve your problem http://blogs.gotdotnet.com/astebner/archive/2007/06/12/3260076.aspx.  The short answer is that repairing .Net 2.0 may resolve this (but if it doesn't, Aaron's post has other options).

     

    Hope this helps,

    Nick Doty - MSFT

    Tuesday, February 12, 2008 4:34 AM

All replies

  •  

    Hi David,

     

    Sorry to hear that you're having trouble!

     

    If you could post your logs somewhere we could all look at them, we might be able to find some clue in the text that could explain your problem.  You can use the collect.exe tool (described here: http://blogs.msdn.com/astebner/archive/2007/08/01/4172276.aspx) to zip up the logs into a vslogs.cab file.  You can then host that vslogs.cab file anywhere (you might try the Windows Live service http://skydrive.live.com), or email it to me at ndoty at microsoft dot com.

     

    Also, I can't tell for sure from your description what the problem is, but if the installer isn't able to find part of the installation, it could be that it's not successfully downloading one of the components.  You can get around this by downloading the full installation package at this link: http://download.microsoft.com/download/6/0/f/60fc5854-3cb8-4892-b6db-bd4f42510f28/dotnetfx35.exe

     

    Hope this helps,

    Nick Doty - MSFT

    Friday, February 8, 2008 11:25 PM
  • Thanks for the quick reply. I sent you an email with the cab but to cover it for the forum, I have downloaded and tried the offline install so component download probably isn't the problem. Thanks.
    Saturday, February 9, 2008 9:47 AM
  •  

    Hi David,

     

    Thanks for sending your logs.  Here's the relevant portion:

     

    Code Snippet

    MSI (s) (30:24) [14:04:42:437]: Assembly Error:Function not defined in specified DLL.

    MSI (s) (30:24) [14:04:42:437]: Note: 1: 1935 2: {06E55FA7-ED36-4A74-8C82-F3D505C50F2E} 3: 0x8002802F 4:  5: CreateAssemblyNameObject 6: System.ServiceModel.WasHosting,Version="3.0.0.0",Culture="neutral",PublicKeyToken="b77a5c561934e089",ProcessorArchitecture="MSIL",FileVersion="3.0.4506.648"
    MSI (s) (30:24) [14:04:42:437]: Product: Microsoft .NET Framework 3.0 Service Pack 1 -- Error 1935.An error occured during the installation of assembly component {06E55FA7-ED36-4A74-8C82-F3D505C50F2E}. HRESULT: 0x8002802F. assembly interface: , function: CreateAssemblyNameObject, assembly name: System.ServiceModel.WasHosting,Version="3.0.0.0",Culture="neutral",PublicKeyToken="b77a5c561934e089",ProcessorArchitecture="MSIL",FileVersion="3.0.4506.648"

    Error 1935.An error occured during the installation of assembly component {06E55FA7-ED36-4A74-8C82-F3D505C50F2E}. HRESULT: 0x8002802F. assembly interface: , function: CreateAssemblyNameObject, assembly name: System.ServiceModel.WasHosting,Version="3.0.0.0",Culture="neutral",PublicKeyToken="b77a5c561934e089",ProcessorArchitecture="MSIL",FileVersion="3.0.4506.648"
    MSI (s) (30:24) [14:04:42:453]: User policy value 'DisableRollback' is 0
    MSI (s) (30:24) [14:04:42:453]: Machine policy value 'DisableRollback' is 0
    Action ended 14:04:42: InstallExecute. Return value 3.

     

     

    Aaron Stebner has a blog post on this particular error message and error code, so I'd suggest looking at this post to see if it will resolve your problem http://blogs.gotdotnet.com/astebner/archive/2007/06/12/3260076.aspx.  The short answer is that repairing .Net 2.0 may resolve this (but if it doesn't, Aaron's post has other options).

     

    Hope this helps,

    Nick Doty - MSFT

    Tuesday, February 12, 2008 4:34 AM