locked
.NET Framework 4.5 RRS feed

  • Question

  • Hi,

    I created vb.net application pointing to .NET framework 4.5. it is working no issues.But the server has v4.0.30319.

    If I deploy my application in server, Will it work or 4.5 framework installation is required on the server?

    Thank You.


    Monday, February 1, 2016 5:46 AM

Answers

  • If your application will run on the server, the server must have the same .NET Framework version you targeted when you developed it. So, .NET 4.5 will have to be installed on the server.

    If you want to avoid the .NET installation on the server, and you did not use any .NET 4.5-specific features in your app, you can retarget all projects in your solution to .NET 4.0 in Visual Studio, rebuild, then deploy to the server


    • Edited by pvdg42 Monday, February 1, 2016 5:00 PM
    • Proposed as answer by 宝宝徐 Tuesday, February 2, 2016 1:50 AM
    • Marked as answer by Kannan Sakkarai Monday, February 8, 2016 7:19 AM
    Monday, February 1, 2016 4:59 PM